[ https://issues.apache.org/jira/browse/LUCENE-2339?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Earwin Burrfoot updated LUCENE-2339: ------------------------------------ Attachment: LUCENE-2339.patch 1 -> I googled all around and nobody mentions any problems save for those with old 1.4 JDK. If problems arise, we can conditionalize code inside - making this optimization NIOFSDir-exclusive is just plain sad, what about MMapDir? 2 -> Don't have strong feelings there, but Uwe insists everything should be consistent and if I use Collection for sync(), then I should use it everywhere. Makes sense probably. 3 -> I feel that static imports are great. They take clutter away, but that's just my opinion. Can change this. 4 -> Applied this, without shady "optimizations". 5 -> ok 6 -> Did that on purporse. Directory.copy(src, dest, true) is way less readable than src.copyTo(dest); src.close(). There's no freaking way to tell what that true means without reading docs. 7 -> I really, really, really, really hate libraries that print something I didn't ask them for. Besides, current implementation prints nothing on similar occasion, so I'm following the trend. > Allow Directory.copy() to accept a collection of file names to be copied > ------------------------------------------------------------------------ > > Key: LUCENE-2339 > URL: https://issues.apache.org/jira/browse/LUCENE-2339 > Project: Lucene - Java > Issue Type: Improvement > Reporter: Earwin Burrfoot > Assignee: Michael McCandless > Attachments: LUCENE-2339.patch, LUCENE-2339.patch, LUCENE-2339.patch > > > Par example, I want to copy files pertaining to a certain commit, and not > everything there is in a Directory. -- This message is automatically generated by JIRA. - You can reply to this email to add a comment to the issue online. --------------------------------------------------------------------- To unsubscribe, e-mail: java-dev-unsubscr...@lucene.apache.org For additional commands, e-mail: java-dev-h...@lucene.apache.org