Usually there's no very good reason, it's just with a bunch of people with
more or lest time and more or less pressure and different habits choose
variable names that reflect how they're thinking about the issue at the
time.

Generally when working on a bit of code if the names are confusing whoever
picks it up next can rename them.

Best,
Erick

On Sun, Aug 6, 2017 at 2:16 AM, 马可阳 <makey...@jd.com> wrote:

> And this:
>
>          Similarity.SimWeight stats
>
>
>
> I bet there are more these things. Just out of curiosity.
>
>
>
>
>
>
>
> [image: 邮件签名]
>
>
>
> *发件人:* 马可阳
> *发送时间:* 2017年8月6日 17:14
> *收件人:* 'java-user@lucene.apache.org'
> *主题:* local variable name question
>
>
>
> In code I can see this:
>
>          final TermContext termState
>
>
>
> while it is instance of TermContext, why not name it termContext rather
> than termState? If termState is more describable name, why not change Class
> name to TermState?
>
>
>
>
>
>
>
> [image: 邮件签名]
>
>
>

Reply via email to