UPD: /s/since remoting 3 has some known stability issues/since JNLP3 has 
some known stability issues/

Remoting 3 seems to be pretty stable according to multiple tests performed 
by Stephen Connolly, James Nord and me.

среда, 12 октября 2016 г., 23:25:01 UTC-7 пользователь Oleg Nenashev 
> Hello,
> For your information, we are going to release a new major version of 
> remoting (remoting 3). This version provides a new JNLP4 protocol, which 
> adds support of Java NIO and improves stability being compared to the JNLP3 
> protocol. 
> Due to the change implementation, it requires some *formally* 
> incompatible changes in the remoting lib and the core. The change required 
> deletion of the JnlpServerHandshake class and rework of its 
> implementation (PR to the core 
> <https://github.com/jenkinsci/jenkins/pull/2492/files>). De-facto we were 
> unable to find any usages of such API. 
> Another important change is the explicit Java 7 requirement. We do not 
> support Java 6 on slaves/agents starting from the 1.610 release (
> Announcement <https://jenkins.io/blog/2015/04/06/good-bye-java6/>), but 
> de-facto remoting users were still able to use this Java version and latest 
> remoting versions in particular edge cases.
> Today at the Jenkins governance meeting 
> <http://meetings.jenkins-ci.org/jenkins-meeting/2016/jenkins-meeting.2016-10-12-18.00.html>
> we decided that these formally incompatible changes are not blockers for 
> including it into Jenkins 2.x.
> As a remoting maintainer, I would like to include JNLP4 into Jenkins core 
> as soon as possible since remoting 3 has some known stability issues. 
> Inclusion into Weeklys allows to get better soak testing before the change 
> actually gets into the next LTS baselines. Newest Jenkins core versions 
> include UI for managing the new protocol, hence users will be able to 
> opt-in and opt-out. Jenkins agents with remoting 2.x will be able to 
> connect to Jenkins master with remoting 3.x, hence the update should be 
> smooth.
> Please respond if you have any concerns regarding the approach.
> Best regards,
> Oleg Nenashev

You received this message because you are subscribed to the Google Groups 
"Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to jenkinsci-dev+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to