I'm using Jenkins to build VS2017 projects (C#), with msbuild 15. My job 
produces compile errors (on a partial class), but running exactly the same 
command on the master (from Jenkins log) just goes fine.
The command (from job's log) is just an msbuild on the .sln file.

When I run a command shell on my master (Windows Server) and start the same 
command from the same path, msbuild compiles OK. I tried to copy the 
environment variables to my Jenkins configuration but it changed nothing.

I just can't figure out how the same command on the same computer can 
produce different results, especially weird compilation errors (the code 
compiles perfectly, even from a command line).

Thanks for helping.

You received this message because you are subscribed to the Google Groups 
"Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to jenkinsci-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to