This is a dup of what I posted to http://stackoverflow.com/q/39526064/131929 but in hind sight I feel this mailing list is more appropriate.

The compiled JSPs produced by the Jetty Jspc Maven Plugin 9.3.11 fail to run on Tomcat 7 due to java.lang.ClassNotFoundException: org.apache.jasper.runtime.JspSourceImports (a Tomcat 8 interface).


I tried to track back the plugin to a specified Tomcat version but got lost at some point in the org.eclipse.jetty:jetty-project, org.eclipse.jetty:apache-jsp, org.mortbay.jasper:apache-jsp, org.mortbay.jasper:jasper-jsp jungle.

Then I found https://dev.eclipse.org/mhonarc/lists/jetty-users/msg04525.html which seems to indicate that I wouldn't want to use any pre-Tomcat 8 versions anyway (due to bugs).

Regards,

--
Marcel Stör, http://frightanic.com
Couchsurfing: http://www.couchsurfing.com/people/marcelstoer
O< ascii ribbon campaign - stop html mail - http://j.mp/1OThh9L
_______________________________________________
jetty-users mailing list
jetty-users@eclipse.org
To change your delivery options, retrieve your password, or unsubscribe from 
this list, visit
https://dev.eclipse.org/mailman/listinfo/jetty-users

Reply via email to