Hi, As discussed in the RFR thread for JDK-8214796 it was suggested to rename the --strip-debug plugin so that --strip-debug could actually perform java debug symbols stripping *and* native debug symbols stripping at once. That's what this patch does. It renames --strip- debug to --strip-java-debug-symbols and --strip-debug just calls -- strip-java-debug-symbols behind the scenes.
Note that --strip-debug-attributes as name would work for me too, but given that we are about to introduce --strip-native-debug-symbols, having the java strippping plugin with a similar name made sense to me. bug: https://bugs.openjdk.java.net/browse/JDK-8218913 webrev: http://cr.openjdk.java.net/~sgehwolf/webrevs/JDK-8218913/01/webrev/ Testing: jlink/jimage tests and jdk/submit (currently running). Thoughts? Thanks, Severin