I just committed a change to create additional ruby_case aliases for all camelCase Java methods in included classes.
It feels right when your head is coding in ruby mode, but I don't know that it adds all that much, and actually obscures the portions of the code that uses java objects. Also, what sort of overhead does all the extra aliases provide?
I think it looks pretty cool though, and I'd like to have it on by default. How nice is:
f.set_size(200, 200)
I meant to ask you last night Charlie why you don't create, e.g., :size= methods for Java setters? That's one rubyism that I think would be nice to add, since you already add reader methods for Java getters.
Thoughts?
/Nick