On Tue, 2014-06-17 at 09:29, j.l.vanderz...@gmail.com wrote:
> On Monday, 16 June 2014 03:33:32 UTC+2, Jacob Quinn wrote:
>>
>> it has nice discoverability properties (tab-completion)
>>
> Oh that's an interesting one. Never consciously thought of the interaction 
> between naming conventions and autocomplete functionality before.
>  
>
>> isn't generally too awkward (though double s's are sometimes weird 
>> `issubset` `issubtype`, and it took me a while to figure out isa() => is 
>> a). 
>>
>
> I take it you don't like camel case? (which makes me wonder: is there a 
> consensus for the idiomatic way to label multi-word identifiers in Julia?) 

http://docs.julialang.org/en/latest/manual/variables/?highlight=camelcase#stylistic-conventions

says:
- Names of variables are in lower case.
- Word separation can be indicated by underscores ('\_'), but use of
  underscores is discouraged unless the name would be hard to read
  otherwise.
- Names of Types begin with a capital letter and word separation is
  shown with CamelCase instead of underscores.
- Names of functions and macros are in lower case, without underscores.
- Functions that modify their inputs have names that end in !. These
  functions are sometimes called mutating functions or in-place
  functions.

I think the general style is: try to use single-word.  If using
multi-word, use one which can be read without _, if that is not possible
us _.

Reply via email to