https://bugs.kde.org/show_bug.cgi?id=385409

--- Comment #59 from Andreas Arnez <ar...@linux.ibm.com> ---
(In reply to Julian Seward from comment #58)
> * you use a construction "mkexpr(mktemp(type, expr))" which I am not
>   sure what the purpose is.  For expressions that will get used more
>   than once, you should bind them to an IRTemp, otherwise multiple uses
>   of the expression will lead to it being code-generated multiple times.
Actually, using an IRTemp is the purpose of this construction.
"mktemp(type, expr)" is just a shortcut for "temp = newTemp(type)"
followed by "assign(temp, expr)".  But since this obviously doesn't help
readability, I'll update the patch to avoid mktemp().

-- 
You are receiving this mail because:
You are watching all bug changes.

Reply via email to