--- Comment #3 from Petros <> ---
Portage reemerged libxcb, mesa and last xorg-server with this specific order
but the problem persists.

equery b  
 * Searching for ... 
dev-util/apitrace-7.1 (/usr/lib64/apitrace/wrappers/ ->
media-libs/mesa-12.0.3 (/usr/lib32/ ->
media-libs/mesa-12.0.3 (/usr/lib64/ ->
media-libs/mesa-12.0.3 (/usr/lib64/

file symbolic link to

file symbolic link to

file ELF 64-bit LSB shared object, x86-64, version 1 (SYSV),
dynamically linked, stripped

At first I though that there had to be some kind of inconsistency with the
naming scheme of the symlinks. But every symlink exists and points where it
should be. 

Below I provide the LD_DEBUG outputs relevanto dri3 from these two appimages
(5.0.0-1 and 5.0.1)

LD_DEBUG="files" ./kdevelop-latest.AppImage 2>&1 | tee | grep xcb-dri3
     11109: [0];  needed by /usr/lib64/ [0]
     11109: [0];  generating link map
     11109:     calling init: /usr/lib64/
     11132: [0];  needed by /usr/lib64/ [0]
     11132: [0];  generating link map
     11132:     calling init: /usr/lib64/
     11135: [0];  needed by /usr/lib64/ [0]
     11135: [0];  generating link map
     11135:     calling init: /usr/lib64/
     11109:     calling fini: /usr/lib64/ [0]
     11135:     calling fini: /usr/lib64/ [0]
     11132:     calling fini: /usr/lib64/ [0]
the whole output ( )

LD_DEBUG="files" ./KDevelop-5.0.1-x86_64.AppImage 2>&1 | tee | grep xcb-dri
     11225: [0];  needed by /usr/lib64/ [0]
     11225: [0];  generating link map
     11225:     /usr/lib64/ error: symbol lookup error:
undefined symbol: xcb_send_request_with_fds (fatal)
kdevelop: symbol lookup error: /usr/lib64/ undefined symbol:

And system-installed kdevelop:
LD_DEBUG="files" /usr/bin/kdevelop
     12432: [0];  needed by /usr/lib64/ [0] [0];  generating link map
     12432:EBUG=calling init: /usr/lib64/
     12440: [0];  needed by /usr/lib64/
     12440: [0];  generating link map
     12440:     calling init: /usr/lib64/

The same command, with the same (in some way) executables, and the same (?)
libraries provided. Why there is this inconsistency in the behavior?

PS I even tried to recompile libxcb, mesa and xorg without -ggdb, but of course
this wasn't an issue.

PS1. I tried to create the output of LD_DEBUG="all" for the 5.0.0-1 version,
but soon enough the log size was over 170MB. No way this thing can be uploaded
with my internet connection. If it is necessary though, let me know.

You are receiving this mail because:
You are watching all bug changes.

Reply via email to