ngraham added a reviewer: Frameworks.
ngraham added inline comments.

INLINE COMMENTS

> knewfilemenu.cpp:859
>          } else {
> +            // Test to see if the user has give "." or ".." as a name
> +            if (name == "." || name == "..") {

has give -> has given

> knewfilemenu.cpp:874
> +                KMessageBox::createKMessageBox(confirmDialog, buttonBox, 
> QMessageBox::Warning,
> +                                   i18n("Cannot create directory with name 
> \"%1\"", name),
> +                                   QStringList(),

This message might be a little bit too terse. How about something that helps 
explain the reason as well, like this?

> "<name>" has a special meaning for the operating system and cannot be used as 
> the name for a folder.

REPOSITORY
  R241 KIO

REVISION DETAIL
  https://phabricator.kde.org/D13805

To: tmarshall, #dolphin, #frameworks
Cc: ngraham, kde-frameworks-devel, michaelh, spoorun, navarromorales, isidorov, 
firef, andrebarros, bruns, emmanuelp

Reply via email to