Try these two:

Basically, the one that worked has three quirks applied:

diff --git a/drivers/usb/core/quirks.c b/drivers/usb/core/quirks.c
index 3116edfcdc18..ff3c70fd919e 100644
--- a/drivers/usb/core/quirks.c
+++ b/drivers/usb/core/quirks.c
@@ -214,6 +214,10 @@ static const struct usb_device_id usb_quirk_list[] = {
        { USB_DEVICE(0x1a0a, 0x0200), .driver_info =
+       /* Corsair Strafe RGB */
+       { USB_DEVICE(0x1b1c, 0x1b20), .driver_info = USB_QUIRK_DELAY_INIT |
        /* Acer C120 LED Projector */
        { USB_DEVICE(0x1de1, 0xc102), .driver_info = USB_QUIRK_NO_LPM },

If the kernels I built do not work, you need to find out what
combination of quirks that can make it work.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Kernel has troule recognizing Corsair Strafe RGB keyboard

Status in linux package in Ubuntu:

Bug description:
  I recently bought a Corsair Strafe RGB keyboard, and while it works
  well when successfully recognized by Ubuntu at boot, that doesn't
  always happen.

  I see messages like this when booting my desktop up:

  [    6.619510] usb 3-10: unable to read config index 0 descriptor/all
  [    6.619543] usb 3-10: can't read configurations, error -110

  They sometimes repeat at 5-second intervals, culminating on a "can't
  set config #1" message or even "unable to enumerate USB device". This
  happens on the logic that deals with a new USB device being connected,
  so when it doesn't work it never gets to the HID drivers part of the
  code. When it does, hid-generic is quite able to control the keyboard,
  though this message appears on dmesg:

  [    6.883811] usbhid 3-10:1.2: couldn't find an input interrupt

  From what I have been able to determine, the Corsair Strafe RGB has three 
inputs, with the last one being used as input/output and having something to do 
with the LEDs. It only has a single USB configuration, though I don't know why 
it times out.

  Searching on Google has a lot of people recommending this userspace
  drive to me: , and I've tried
  it, but it seems to be more about programming lighting effects into
  the keyboard than in controlling its basic operation, which is all I'm
  interested in. Its daemon was supposed to handle that part too, but it
  didn't fix those connection errors on boot.

  I have the following boot parameter set in my kernel, following advice
  from ckb-next's README, but it doesn't see to have an appreciable
  effect on my success rate:


  ckb-next recommended 0x20000408, but I added the HID_QUIRK_MULTI_INPUT
  as well in an attempt to improve things, without success.

  GRUB is always able to correctly identify the keyboard and get it to
  work, too, which makes the fact that the full kernel can't always do
  it a little more frustrating.

  I would be happy to provide any extra information you require on this

  ProblemType: Bug
  DistroRelease: Ubuntu 16.10
  Package: linux-image-4.8.0-45-generic 4.8.0-45.48
  ProcVersionSignature: Ubuntu 4.8.0-45.48-generic 4.8.17
  Uname: Linux 4.8.0-45-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
  ApportVersion: 2.20.3-0ubuntu8.2
  Architecture: amd64
   /dev/snd/controlC1:  bira       2322 F.... pulseaudio
   /dev/snd/controlC0:  bira       2322 F.... pulseaudio
  CurrentDesktop: i3
  Date: Sat Apr  1 10:23:52 2017
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2015-02-24 (767 days ago)
  InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
   eth0      no wireless extensions.
   lo        no wireless extensions.
  MachineType: Gigabyte Technology Co., Ltd. Z97M-D3H
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.8.0-45-generic 
root=UUID=d1db423d-2a50-49ac-b4e7-fd50d73afaff ro quiet splash 
   linux-restricted-modules-4.8.0-45-generic N/A
   linux-backports-modules-4.8.0-45-generic  N/A
   linux-firmware                            1.161.1
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install) 05/30/2014
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: F5
  dmi.board.asset.tag: To be filled by O.E.M. Z97M-D3H
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.board.version: x.x
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
  dmi.chassis.version: To Be Filled By O.E.M.
dmi:bvnAmericanMegatrendsInc.:bvrF5:bd05/30/2014:svnGigabyteTechnologyCo.,Ltd.:pnZ97M-D3H:pvrTobefilledbyO.E.M.:rvnGigabyteTechnologyCo.,Ltd.:rnZ97M-D3H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvrToBeFilledByO.E.M.: Z97M-D3H
  dmi.product.version: To be filled by O.E.M.
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to