@pHeLiOn: Thanks for putting in the effort! Seeing that this is not resolved 
yet, I figured that though I'm not a kernel-hacker/sysadmin-guru by a long 
shot, I'll throw my tidbits in, in the faint hope that someone gets onto the 
right track.
(For rememberance: Acer Aspire E13, Intel Celeron N2940, 4GB RAM, changed 
standard HD for a 250G SSD)

The 'other' bug I mentioned above was (I believe) resolved by adding the 
statement intel_idle.max_cstate=1 in the grub configuration file. However, my 
first inquiries into the problem (System freezes, not resolvable by anything 
(didnt try remote access, though)) pointed me to a potential problem with the 
SSD HD. Now, I cannot, for the life of me, remember what it was, exactly, but 
it was something along the lines of Point No. 6 on this site:
I remembered this because you narrowed it down to some CPU types PLUS SSD, so, 
maybe there's a hint somewhere.

In my above Post, I mentioned that my problem was 'fixed' in 18.04 by 
downgrading the kernel, as mentioned.
Well, it IS fixed in a way, but there remain some oddities - for example: After 
Boot, the cooling fan is on (running at a moderate pace at first) no matter 
what, even after a cold boot. It takes putting the system into suspend and out 
again (which, as mentioned, works now!) so that the fan is turned off 
completely - and, somewhat worringly, stays off. I've not tested running the 
system at full power to see if the cooling fan comes on again, when required - 
so as of now, I take it a bit on 'good faith' that it will :)

These are my further observations - hope it helps somehow!

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Suspend fails in Ubuntu and Kubuntu 18.04 but works fine in Ubuntu and
  Kubuntu 17.10 (and on Kubuntu 18.04 using kernel 4.14.47)

Status in linux package in Ubuntu:

Bug description:
  I have installed Kubuntu 18.04 on 3 different machines (my friend's
  and my own) with no suspend problems but my HP Pavilion 11 x360 does
  not suspend.

  It suspends fine with Ubuntu 17.10, Kubuntu 17.10, Devuan Jesse,
  Devuan ASCII and Windows 10 but fails with Ubuntu 18.04 and Kubuntu

  I have also tried suspend using a live USB of 18.04 on this machine
  and it fails in the same way, so does not appear to be caused by any
  additional programs that I had installed.

  By installing an older kernel (4.14) on Kubuntu 18.04 the suspend
  function works as expected.

  Running Kubuntu 18.04 with kernels 4.15, 4.16, 4.17 results in the
  suspend failure that freezes the machine and requires a hard reset.

  Correct behaviour is - 

  Screen goes blank, fan goes off, power LED flashes to show machine is
  in suspend. Pressing power button triggers 'resume' function.

  What happens - 

  Screen goes blank, fan stays on, power LED stays on. Machine stays in
  this state and does not respond to any keyboard interaction, mouse
  movement or power button presses.

  Ctrl + Alt + f1 (or f2, f3, f4 etc) does not get any response.

  The only way to use the machine is to shut down by holding down the
  power button.

  Checking the logs suggests that the machine believes it is in suspend mode 
sleep [deep] when it isn't.

  Having to hard reset to get any response means that the kernel logs
  say no more than sleep [deep]

  pm-suspend also results in the same problems with kernels 4.15 and
  4.16, but works fine with 4.14.

  It is curious that a machine that suspends fine on an earlier 4.14
  kernel no longer works with 4.15 and above, whilst 3 other machines
  (including one with pretty similar hardware) do not exhibit this

  There are only a handful of questions about it on the forums but at
  least 3 other people have the same problem:



  I am attempting to round up anyone else with the same issue and point
  them to this bug report.

  My laptop is HP Pavilion x360 11-n013na 
  Matalaks is Acer Aspire ES1-511
  collisionTwo has XPS 9560

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to