Probably related:

Since the introduction of kernel 4.8 I've been experiencing color 
banding on my Lenovo G50-80 notebook. I also had reports of the same 
symptoms on the G50-70 model.

I figured out that the problem had been introduced by commit 

The G50-80's LCD panel supports 6bpc, but is now set to 8bpc,
and the system probably falls back to 6bpc
without any dithering, which result in heavily banded gradients.

I fixed it for myself by adding an EDID quirk for that particular LCD 
panel (see the attached patch). It's unknown to me, however, if there 
are any other panels affected by the issue, so maybe a more general
solution might be desirable.

diff --git a/drivers/gpu/drm/drm_edid.c b/drivers/gpu/drm/drm_edid.c
index fad3d44e4642..ee3124bcae87 100644
--- a/drivers/gpu/drm/drm_edid.c
+++ b/drivers/gpu/drm/drm_edid.c
@@ -147,6 +147,9 @@  static const struct edid_quirk {
        /* Medion MD 30217 PG */
        { "MED", 0x7b8, EDID_QUIRK_PREFER_LARGE_75 },
+       /* Fix for Lenovo G50 */
+       { "SDC", 18514, EDID_QUIRK_FORCE_6BPC },
        /* Panel in Samsung NP700G7A-S01PL notebook reports 6bpc */
        { "SEC", 0xd033, EDID_QUIRK_FORCE_8BPC },

** Tags added: banding bionic color edid i915 lenovo-g50

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Colour banding in Lenovo G50-80 laptop display (i915)

Status in linux package in Ubuntu:

Bug description:
  Colour bandind is visible everywhere in the system. I believe it's not
  a hardware problem, since booting with 'nomodeset' works as expected
  and the previously installed Ubuntu 14.04 also worked.

  I tried installing kernel 4.18.0-16.17 from ppa:canonical-kernel-
  team/ppa but the problem remained.

  There were already similar bugs, , and, but the fixes provided for
  those bugs did not work for my specific monitor.

  cat /proc/version_signature
  Ubuntu 4.15.0-46.49-generic 4.15.18

  sudo lspci -vnvn
  00:00.0 Host bridge [0600]: Intel Corporation Haswell-ULT DRAM Controller 
[8086:0a04] (rev 0b)
        Subsystem: Lenovo Haswell-ULT DRAM Controller [17aa:390b]
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- 
<MAbort+ >SERR- <PERR- INTx-
        Latency: 0
        Capabilities: [e0] Vendor Specific Information: Len=0c <?>
        Kernel driver in use: hsw_uncore

  00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT 
Integrated Graphics Controller [8086:0a16] (rev 0b) (prog-if 00 [VGA 
        Subsystem: Lenovo Haswell-ULT Integrated Graphics Controller [17aa:390b]
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- 
<MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 46
        Region 0: Memory at b0000000 (64-bit, non-prefetchable) [size=4M]
        Region 2: Memory at a0000000 (64-bit, prefetchable) [size=256M]
        Region 4: I/O ports at 4000 [size=64]
        [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
                Address: fee02004  Data: 4023
        Capabilities: [d0] Power Management version 2
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA 
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [a4] PCI Advanced Features
                AFCap: TP+ FLR+
                AFCtrl: FLR-
                AFStatus: TP-
        Kernel driver in use: i915
        Kernel modules: i915

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to