I tried running it and get an error. Tried both with Sudo and without
(had "sudo apt install i2c-tools" before).

florin@florin-XPS-17-9720:~/Downloads$ sh ./get-tp-fw-ver.sh 
./get-tp-fw-ver.sh: 22: Bad substitution

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Touchpad problem detecting working area on Dell XPS

Status in linux package in Ubuntu:

Bug description:
  I am using a new Dell XPS 17 with the latest Ubuntu (22.10). One bug I
  could see is the touchpad sensitivity. Sometimes, randomly, the upper
  part of the touchpad is the only one working, most of its surface does
  not work. If the movement starts in the working area, then you can use
  the whole touchpad until you lift the finger. After a while it seems
  to recover by itself. My feeling is that this is somehow related to
  the sensitivity of the touchpad (some instability) or related to the
  system that disables the touchpad while writing (again, some buggy
  detection). While writing this text I experienced the bug twice, for
  instance, intermittently.

  ProblemType: Bug
  DistroRelease: Ubuntu 22.10
  Package: linux-image-5.19.0-23-generic 5.19.0-23.24
  ProcVersionSignature: Ubuntu 5.19.0-23.24-generic 5.19.7
  Uname: Linux 5.19.0-23-generic x86_64
  ApportVersion: 2.23.1-0ubuntu3
  Architecture: amd64
   /dev/snd/controlC1:  florin     1581 F.... pipewire
                        florin     1584 F.... wireplumber
   /dev/snd/controlC0:  florin     1584 F.... wireplumber
   /dev/snd/seq:        florin     1581 F.... pipewire
  CasperMD5CheckResult: pass
  CurrentDesktop: ubuntu:GNOME
  Date: Tue Nov 22 17:25:52 2022
  InstallationDate: Installed on 2022-10-24 (29 days ago)
  InstallationMedia: Ubuntu 22.10 "Kinetic Kudu" - Release amd64 (20221020)
  MachineType: Dell Inc. XPS 17 9720
  ProcFB: 0 i915drmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.19.0-23-generic 
root=UUID=99833626-9acf-4145-9fee-2cbbe47e4d33 ro quiet splash vt.handoff=7
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
   linux-restricted-modules-5.19.0-23-generic N/A
   linux-backports-modules-5.19.0-23-generic  N/A
   linux-firmware                             20220923.gitf09bebf3-0ubuntu1
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 09/08/2022
  dmi.bios.release: 1.11
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.11.0
  dmi.board.name: 0KNF8J
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
  dmi.product.family: XPS
  dmi.product.name: XPS 17 9720
  dmi.product.sku: 0AFF
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~kernel-packages
Post to     : kernel-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~kernel-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to