On Fri, May 22, 2026 at 08:24:03PM +0000, David Matlack wrote:
> During a Live Update, preserved devices must be allowed to continue
> performing memory transactions so the kernel cannot change the fabric
> topology, including bus numbers, since that would require disabling
> and flushing any memory transactions first.
> 
> To keep bus numbers constant, always inherit the secondary and
> subordinate bus numbers assigned to bridges during scanning, instead of
> assigning new ones, if any PCI devices are being preserved. Note that
> the kernel inherits bus numbers even on bridges without any downstream
> endpoints that were preserved. This avoids accidentally assigning a
> bridge a new window that overlaps with a preserved device that is
> downstream of a different bridge.
> 
> If a bridge is scanned with a broken topology or has no bus numbers
> set during a Live Update, refuse to assign it new bus numbers and refuse
> to enumerate devices below it until the Live Update is finished. This is
> a safety measure to prevent topology conflicts.
> 
> Require that CONFIG_CARDBUS is not enabled to enable
> CONFIG_PCI_LIVEUPDATE since inheriting bus numbers on PCI-to-CardBus
> bridges requires additional work but is not a priority at the moment.
> 
> Signed-off-by: David Matlack <[email protected]>
> ---
>  .../admin-guide/kernel-parameters.txt         |  6 +-
>  drivers/pci/Kconfig                           |  2 +-
>  drivers/pci/liveupdate.c                      | 83 ++++++++++++++++++-
>  drivers/pci/liveupdate.h                      | 14 ++++
>  drivers/pci/probe.c                           | 17 +++-
>  include/linux/pci_liveupdate.h                |  4 +
>  6 files changed, 119 insertions(+), 7 deletions(-)
> 

[...]

> +             incoming = pci_liveupdate_flb_get_incoming();
> +             if (!incoming) {
> +                     dev->liveupdate.inherit_buses = false;
> +                     goto out;
> +             }
> +
> +             /*
> +              * It is safe to sample incoming->ser->nr_devices and then
> +              * drop the rwsem since nr_devices will only decrease. Thus the
> +              * only "race" is that the current scan will be overly
> +              * conservative and force bus inheritance.
> +              */
> +             dev->liveupdate.inherit_buses = incoming->ser->nr_devices;

Nit: inherit_buses is a bool, while compiler will handle it correctly,
maybe we could:

dev->liveupdate.inherit_buses = !!incoming->ser->nr_devices 

OR

dev->liveupdate.inherit_buses = (incoming->ser->nr_devices > 0)

for readability?

> +             pci_liveupdate_flb_put_incoming();
> +     }
> +
> +out:
> +     return dev->liveupdate.inherit_buses;
> +}
> +
 
[...]

>               /*
> @@ -1497,8 +1501,7 @@ static int pci_scan_bridge_extend(struct pci_bus *bus, 
> struct pci_dev *dev,
>                * do in the second pass.
>                */
>               if (!pass) {
> -                     if (pcibios_assign_all_busses() || broken)
> -
> +                     if (assign_new_buses || broken)
>                               /*
>                                * Temporarily disable forwarding of the
>                                * configuration cycles on all bridges in
> @@ -1512,6 +1515,11 @@ static int pci_scan_bridge_extend(struct pci_bus *bus, 
> struct pci_dev *dev,
>                       goto out;
>               }
>  
> +             if (liveupdate) {
> +                     pci_err(dev, "Cannot reconfigure bridge during Live 
> Update, skipping\n");
> +                     goto out;
> +             }

Quite helpful! Thanks :)

> +
>               /* Clear errors */
>               pci_write_config_word(dev, PCI_STATUS, 0xffff);
>  
> @@ -1572,6 +1580,7 @@ static int pci_scan_bridge_extend(struct pci_bus *bus, 
> struct pci_dev *dev,
>       pci_write_config_word(dev, PCI_BRIDGE_CONTROL, bctl);
>  
>       pm_runtime_put(&dev->dev);
> +     pci_liveupdate_scan_bridge_end(dev, pass);
>  
>       return max;
>  }

With the minor nit above,
Reviewed-by: Pranjal Shrivastava <[email protected]>

Thanks,
Praan

Reply via email to