On 2017.08.07 19:31, Brendan Coupe wrote:
I already tried the libalkimia trick and it did not work this time.
That would only work if it was an alkimia file which was missing, and it was missing because your alkimia install was broken.


I was running with -j 8. I tried -j 1 and it took a lot longer to fail. I added -d to -j 1 and it also failed. I've copied the last part of the output below (I switched GMail to plain text mode, I hope it works).
Mail formatting is good - thanks.

======================================
Updating goal targets....
Considering target file
'kmymoney/dialogs/settings/CMakeFiles/settings_autogen.dir/build'.
File 'kmymoney/dialogs/settings/CMakeFiles/settings_autogen.dir/build'
does not exist.
[snip....]
      Must remake target '//kmymoneysettings.h'.
I probably snipped too many lines, but the problem is it can't find kmymoneysettings.h. That file is not in the source, but gets created in $build_dir/kmymoney. So we need to figure out why it isn't being made.

First - what sources are you using? If you are pulling from git head of the 4.8 branch, confirm that "git status" doesn't show anything amiss.

Second - are you building in tree, or out of tree. The latter is recommended as safer.

If that's not enough, we may have to track down where in the build process that file SHOULD be created, and why it's not happening.

Jack


On Mon, Aug 7, 2017 at 10:57 AM, Jack <ostrof...@users.sourceforge.net> wrote:
> Hello Brendan,
>
> On 2017.08.07 12:28, Brendan Coupe wrote:
>>
>> I have been compiling KMM from source for many years. I have been using
>> the 4.8 branch recently.
>>
>> I upgraded from Fedora 25 to Fedora 26 a couple of weeks ago. Compiling >> fails pretty early in the process. See the last part of the output below. It
>> compiled from source without any issues prior to the OS upgrade.
>>
>> Any idea what is going wrong?
>>
>> =======================================================
>> *Generating MOC source EWIEGA46WW/moc_lendborrowwizardpage.cppGenerating >> MOC source JKU67JSAFJ/moc_KDChartTernaryPointDiagram.cppGenerating MOC >> source EWIEGA46WW/moc_loanamountwizardpage.cppGenerating MOC compilation >> mocs_compilation.cpp[ 6%] Built target kmm_kdchart_autogenGenerating MOC >> source EWIEGA46WW/moc_loanattributeswizardpage.cppGenerating MOC source
>> EWIEGA46WW/moc_namewizardpage.cppGenerating MOC source
>> EWIEGA46WW/moc_newcalculateloanwizardpage.cppGenerating MOC source
>> EWIEGA46WW/moc_newgeneralinfowizardpage.cppGenerating MOC source
>> EWIEGA46WW/moc_newintrowizardpage.cppGenerating MOC source
>> EWIEGA46WW/moc_newpaymentswizardpage.cppGenerating MOC source
>> EWIEGA46WW/moc_paymenteditwizardpage.cppGenerating MOC source
>> EWIEGA46WW/moc_paymentfrequencywizardpage.cppGenerating MOC source
>> EWIEGA46WW/moc_paymentwizardpage.cppGenerating MOC source
>> EWIEGA46WW/moc_previouspaymentswizardpage.cppGenerating MOC source
>> EWIEGA46WW/moc_recordpaymentwizardpage.cppGenerating MOC source
>> EWIEGA46WW/moc_schedulewizardpage.cppGenerating MOC source
>> EWIEGA46WW/moc_summaryeditwizardpage.cppGenerating MOC source
>> EWIEGA46WW/moc_summarywizardpage.cppGenerating MOC source
>> EWIEGA46WW/moc_variableinterestdatewizardpage.cppGenerating MOC
>> compilation
>> mocs_compilation.cpp[ 6%] Built target newloanwizard_autogenmake: ***
>> [Makefile:163: all] Error 2*
>> **=======================================================
>
>
> First please consider sending plain text and not HTML to the list - you can
> see it messes up wrapping.
>
> This seems similar to a problem you had last October. Have you tried "make > -d" (or some slightly less verbose variant) to get debugging info? What -j > value are you using? I believe at that time, make (or gcc?) couldn't find > some header file, which you fixed by removing and reinstalling libalkimia.
>
> Jack


Reply via email to