Hello,

Since Knot 2.4.0 zone timers database is required (not optional).
Could you purge the timers and confdb and start the server with
the textual configuration only? Have you built the package with
the embedded LMDB or is an external LMDB available?

We know users running the latest Knot successfully.

Daniel

On 02/27/2017 10:32 AM, Abdulkareem H. Ali wrote:
Hi All,

I built Knot 2.4.1 rpm and tried it on CentOS7. The server isn't reading
any of our zones with an error of:

"failed to load persistent timers (invalid parameter)"

Therefore it won't accept any notifies form master and won't read or
transfer any zone. Even when I do "knotc refresh ZONE" it will fail
saying zone is unknow.

This is an upgrade from Knot 2.2, and same configs doesn't complain
about anything and the server starts fine using that version, and load
zones, and respond to DNS queries without a problem.

I tried to find a procedure for a first time install for Knot and see if
there is any required initialization that needs to be done but no luck.

Have anyone tried Knot 2.4.1 with CentOS 7 please and successfully had
it running?

Note that I tried:

knotc conf-check (responds with: Configuration is valid)

knotc conf-read (shows all zones and template configs being read and
doesn't show any warning or error)

knotc conf-init
knotc conf-import /etc/knot/knot.conf

Either one of those will generate confdb. However, conf-init generates
it but then Knot doesn't show anything in the logs (set to debug), but
does generate timers folder.

But conf-import show same logs with same errors above, and still won't
load any of our zones.

I'm using these template settings:

""
mod-rrl:
  - id: default
    rate-limit: 200     # Allow 200 resp/s for each flow
    slip: 2  # Every other response slips

template:
  - id: default
    storage: /var/lib/knot/zones
    journal-db: journals
    timer-db: timers
    zonefile-sync: 60
    semantic-checks: on
    global-module: mod-rrl/default
""

I'd appreciate any suggestion please.

I'm new to this list, so if this is not where I was suppose to send this
please accept my apologize.


Thanks,
Kareem.



_______________________________________________
knot-dns-users mailing list
[email protected]
https://lists.nic.cz/cgi-bin/mailman/listinfo/knot-dns-users

Reply via email to