https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=42310

--- Comment #69 from Tomás Cohen Arazi (tcohen) <[email protected]> ---
Created attachment 203289
  -->
https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=203289&action=edit
Bug 42310: Normalize calendar tables

Replace the two overloaded tables (repeatable_holidays, special_holidays)
with four purpose-specific tables:

- library_weekly_closures: weekly closed days (e.g. every Sunday)
- library_repeating_closures: annual repeating closures (e.g. Dec 25)
- library_single_closures: one-off closures with a DATE column
- library_closure_exceptions: open overrides with a DATE column

All use library_id FK and follow current community standards. It points to API
usage in a short term so it follows the API naming conventions.

Signed-off-by: Tomás Cohen Arazi <[email protected]>
Signed-off-by: David Nind <[email protected]>
Signed-off-by: Martin Renvoize <[email protected]>
Signed-off-by: Tomás Cohen Arazi <[email protected]>

-- 
You are receiving this mail because:
You are watching all bug changes.
_______________________________________________
Koha-bugs mailing list -- [email protected]
To unsubscribe send an email to [email protected]
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/

Reply via email to