I'm running a python process (django server) in a pod, which writes its output to stdout, but attempting to view the logs with "kubctl logs" shows nothing.

I'm similarly unable to view the logs when I run it as a standalone docker process (i.e., using "docker logs") - unless I run the docker container using "-dt", at which point I can see the logs just fine using "docker logs".


The problems, here though, are:

1) kubectl doesn't have a flag combo of -dt that I can use to launch the container. 2) If I try to use kubectl to launch using just "-t", it forces me to use "-i" as well - which then puts me into interactive mode, which is not what I want. 3) It seems like I'm doing something wrong here - i.e., I shouldn't need to be jumping through all these hoops altogether to be getting log output.

Can anyone please advise what's the correct way to handle this?

Thanks,

DR

--
You received this message because you are subscribed to the Google Groups "Kubernetes 
user discussion and Q&A" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to kubernetes-users+unsubscr...@googlegroups.com.
To post to this group, send email to kubernetes-users@googlegroups.com.
Visit this group at https://groups.google.com/group/kubernetes-users.
For more options, visit https://groups.google.com/d/optout.

Reply via email to