Hello again,

I've continued my attempts to get the HASP dongle working, but with no success:

Downloaded kvm-72.tar.gz through kvm-87.tar.gz to find out when the
problem first appear, as kvm-72 is working. Unfortunately, kvm-72
through kvm-82 fails to compile on my Debian system with kernel 2.6.30
and gcc 4.3, and kvm-83 crashes in the same way that kvm-87 crashes.

I have also tested two other USB devices: a C-Pen (www.cpen.com) and a
GEM card reader, both successfully. So it seems it is the HASP
dongle/driver combo which is doing something naughty that makes KVM
versions newer than kvm-72 crash...

Anyone got any ideas what I might try out to find the cause for the crashes?

On Thu, Jul 2, 2009 at 5:42 PM, G<tjmad...@gmail.com> wrote:
> Hello,
> As the subject says, kvm crashes for me, when I'm trying to use an
> Aladdin HASP USB dongle.
> Short background: for over a year I have used kvm to run a Windows XP
> Professional 32bit SP2 install with the EnCase software package, which
> requires an Aladdin HASP USB dongle. The last working installation
> used Debian unstable's kvm-72 and qemu 0.10.5 packages, together with
> linux (and Win XP 32 bit SP2, EnCase 6.13 (I have prevoiusly
> also successfully used EnCase 4.22a with an older Aladdin HASP USB
> dongle)). In an attempt to increase disk performance I upgraded to
> kvm-87, and then my problems began.
> Running kvm-87 works fine up until the point when the Aladdin HASP
> driver wants to talk to the dongle. For example, I did one test run
> with a clean Windows install where I installed EnCase 6.13 and the
> dongle drivers, started up EnCase in Acquisition Mode, acquired the
> running virtual hard disk while playing Solitaire (to keep both disk
> and graphics going), and it went fine. Then, when I enter "usb_add
> host:0529:0001" in the qemu monitor it takes somewhere between a few
> seconds up to a minute or two before kvm crashes and dumps core.
> Only installing the drivers without entering "usb_add host:0529:0001"
> in the qemu monitor does not cause problems, I can keep on using the
> system (as just described in previous paragraph).
> Only entering "usb_add host:0529:0001" in the qemu monitor (and then
> having "Found new hardware" pop up and selecting "Cancel") without
> having the drivers installed does not cause problems, I can keep on
> using the system.
> I have tried out the things described at http://www.linux-kvm.org/page/Bugs ;
> -no-kvm-irqchip and -no-kvm-pit only slows the system down, it still crashes.
> -no-kvm crashes on startup (see the attached file crash3.txt).
> All these test runs make me guess that the problem lies somewhere in
> kvm's USB code, and is triggered by the Aladdin HASP drivers, unless
> there is something fundamentally wrong with my install (the immediate
> crash with -no-kvm might indicate that). I can however see nothing
> obviously wrong with my install and therefore suspect kvm.
> Three files, describing three different test runs (including gdb
> backtraces) which all crash at some point, are attached to this mail.
> They are generated on a Fujitsu Siemens Celsius workstation with an
> "Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz" (according to /proc/cpuinfo),
> 4GB RAM, running Linux 2.6.30 x86_64, and kvm-87 and qemu-kvm-0.10.5
> downloaded from Sourceforce using the link on
> http://www.linux-kvm.org/page/Downloads . No Debian kvm or qemu
> packages installed, and I have made sure that I really use the kvm-87
> kernel modules and not the ones that come with the kernel.
> The exact same problems also show up when running the same kvm/qemu
> versions and the same virtualized versions (of Win and EnCase), and on
> both Linux and 2.6.30, on a HP ProLiant DL380 G5 with 12GB
> RAM and an Intel Xeon 5160 (don't know if it's a quad core or two dual
> cores; in any case, it's four cores total). That is the intended
> production system, and the system on which I have successfully been
> running Windows and EnCase on older kvm versions (kvm-72 is working, I
> don't remember if I've used any version before that).
> qemu-kvm-0.10.5 is installed like this:
> ./configure
> make
> make install
> kvm-87 is installed like this:
> ./configure --enable-debug
> make
> make install
> I see nothing wrong with those installation methods, although I get no
> "kvm" binary, and instead have to use qemu-system-x86_64 to run.
> I'd be happy to do more test runs using any flags you want me to try
> in order to pin this problem down. Unless, of course, I've done
> something wrong, in which case I will gladly receive instructions on
> how to correctly use kvm to get this working (but it's working with
> kvm-72...). I have already tried several earlier versions of kvm such
> as Debian unstable's kvm-85, kvm-83, and kvm-79, using the kvm modules
> from the kernel tree, and they all crash too. But kvm-72 works with
> the kvm modules from the kernel.
> I can also supply more output from kvm compilation, kernel config etc.
> in case that would be of any help.
> Thanks in advance.
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to