Hi Paolo,

> -----Original Message-----
> From: Paolo Bonzini <[email protected]>
> Sent: Wednesday, October 16, 2019 3:14 PM
> To: Jianyong Wu (Arm Technology China) <[email protected]>;
> [email protected]; [email protected]; [email protected];
> [email protected]; [email protected]; [email protected];
> [email protected]; Mark Rutland <[email protected]>;
> [email protected]; Suzuki Poulose <[email protected]>
> Cc: [email protected]; [email protected];
> [email protected]; [email protected]; Steve Capper
> <[email protected]>; Kaly Xin (Arm Technology China)
> <[email protected]>; Justin He (Arm Technology China)
> <[email protected]>; nd <[email protected]>
> Subject: Re: [PATCH v5 5/6] ptp: arm64: Enable ptp_kvm for arm64
> 
> On 16/10/19 09:10, Paolo Bonzini wrote:
> > On 16/10/19 05:52, Jianyong Wu (Arm Technology China) wrote:
> >> This func used only by kvm_arch_ptp_get_clock and nothing to do with
> >> kvm_arch_ptp_get_clock_fn. Also it can be merged into
> >> kvm_arch_ptp_get_clock.
> >>
> >
> > Your patches also have no user for kvm_arch_ptp_get_clock, so you can
> > remove it.
> 
> Nevermind.  I misread patch 2.  However, to remove the confusion, can you
> rename kvm_arch_ptp_get_clock_fn to kvm_arch_ptp_get_crosststamp?
> 

the suffix of this function name is reserved from its arch-independent caller 
ptp_kvm_get_time_fn, so if I change this function name
It will be better change them whole. I think "ptp_get_crosststamp" is a better 
suffix.

Thanks
Jianyong 

> Paolo

Reply via email to