approved On 9/25/07, Max Carlson <[EMAIL PROTECTED]> wrote: > > Change 20070925-maxcarlson-d by [EMAIL PROTECTED] on 2007-09-25 > 16:15:32 PDT > in /Users/maxcarlson/openlaszlo/trunk > for http://svn.openlaszlo.org/openlaszlo/trunk > > Summary: Fix explicit replicator > > New Features: > > Bugs Fixed: LPP-4664 - test/explicit-replicators/replicator.lzx > visually deletes last two items when the second-to-last item is > clicked and ... > > Technical Reviewer: hminsky > QA Reviewer: [EMAIL PROTECTED] > Doc Reviewer: (pending) > > Documentation: > > Release Notes: > > Details: Per abargull and hminsky's suggestions, changed > this._pointer.p to this.dataset for clarity, added destroy() to > prevent memory leaks, _updateChildren() deals with a single node > correctly, createChildren() calls super.createChildren(), > __adjustVisibleClones() uses this.container instead of this.parent to > lock/unlock layouts. > > > Tests: See LPP-4664. > > Files: > M lps/components/utils/replicator/replicator.lzx > > Changeset: http://svn.openlaszlo.org/openlaszlo/patches/20070925- > maxcarlson-d.tar >
-- Henry Minsky Software Architect [EMAIL PROTECTED]
