FWIW, the reason I use that pattern is because you couldn't reliably
subclass Array in some runtimes. We should check that that is still
the case. If not, we ought to be more accurate, as surely it will
help performance. (I am looking at 4441 as we speak...)
On 2007-09-26, at 19:09 EDT, André Bargull wrote:
Approved,
[although I'm not a fan of array-type-checking through "length" as
it can lead to some subtle bugs (see i.e. LPP-4441). But it is a
common pattern, so approved!]
Max Carlson wrote:
Change 20070925-maxcarlson-d by [EMAIL PROTECTED] on 2007-09-25
16:15:32 PDT
in /Users/maxcarlson/openlaszlo/trunk
for http://svn.openlaszlo.org/openlaszlo/trunk
Summary: Fix explicit replicator
New Features:
Bugs Fixed: LPP-4664 - test/explicit-replicators/replicator.lzx
visually deletes last two items when the second-to-last item is
clicked and ...
Technical Reviewer: hminsky
QA Reviewer: [EMAIL PROTECTED]
Doc Reviewer: (pending)
Documentation:
Release Notes:
Details: Per abargull and hminsky's suggestions, changed
this._pointer.p to this.dataset for clarity, added destroy() to
prevent memory leaks, _updateChildren() deals with a single node
correctly, createChildren() calls super.createChildren(),
__adjustVisibleClones() uses this.container instead of this.parent
to lock/unlock layouts.
Tests: See LPP-4664.
Files:
M lps/components/utils/replicator/replicator.lzx
Changeset: http://svn.openlaszlo.org/openlaszlo/patches/20070925-
maxcarlson-d.tar
--
Official OpenLaszlo-Committer ^_^