Hello,

Just now subscribed to the list.

I just had the exact same experience as Eric Doherty who posted on Nov 2, 2016. 
Here is his post:


latex2rtf support

I have received this message

Error! end of file reached before '\begin|{|document|}' was found

and now the whole file is wiped. Like gone. 0 kB, no text, nothing.

How do I recover it and what happened?!?!?!?!?

My tex file has been wiped, 0 kb, absolutely nothing in it. I got the exact 
same error message. I know for a fact that the file was there because I had 
just compiled it in texniccenter from the location where LaTeX2RTF was looking 
for it. Furthermore, I had successfully converted it to RTF on multiple 
previous occassions. I am using version 2.3.11 on Windows 10.

I believe I know what happened, although not exactly why it happened. I wanted 
to save the RTF file in another folder (not the one the latex files are in). I 
clicked the "..." toggle to the right of the "RTF file:" pane and navigated to 
the location where I intended to save the file as an RTF. However, upon 
re-examination of the "RTF file:" pane, the intended file name in the pane is 
the name of my tex file (myfile.tex) and the location is the folder that all 
the latex files are in! So I overwrote the tex file with what the product of 
the conversion was supposed to be (if that makes sense).

Upon further investigation, this appears to be a problem with how the RTF file 
pane responds to being changed by selecting a destination folder. Often times 
when you go to a destination folder and enter a file name, it still reverts to 
the source folder and enters the myfile.tex name into the pane. Strange 
behavior. I tried opening and closing latex2rtf a few times and it continued to 
do this.

Now all I have on my computer (which backs up to the OneDrive cloud) is the 
most recent pdf that I compiled in texniccenter. I am hoping I can access an 
older version of the tex file on a computer at home that is not connected to 
the cloud at the moment - but unfortunately that will entail redoing a lot of 
revisions that I have made recently. Hopefully that works though, because 
otherwise that is a LOT of work right out the window (including some 
ridiculously large tables).

If you have any suggestions, I'm all ears. But I suspect that it is gone. Since 
this looks to be a re-occurring phenomenon, it might be worthwhile for people 
to create a duplicate of their latex files in a safe place before trying to use 
LaTex2RTF. As I mentioned, I have had no problems before and have good success 
with LaTex2RTF until now.

Thanks,
Art
------------------------------------------------------------------------------
Developer Access Program for Intel Xeon Phi Processors
Access to Intel Xeon Phi processor-based developer platforms.
With one year of Intel Parallel Studio XE.
Training and support from Colfax.
Order your platform today. http://sdm.link/xeonphi
_______________________________________________
Latex2rtf-users mailing list
Latex2rtf-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/latex2rtf-users

Reply via email to