root@RECOVERY:/# ubinfo /dev/ubi1
Volumes count:                           0
Logical eraseblock size:                 258048 bytes, 252.0 KiB
Total amount of logical eraseblocks:     15 (3870720 bytes, 3.7 MiB)
Amount of available logical eraseblocks: 0 (0 bytes)
Maximum count of volumes                 128
Count of bad physical eraseblocks:       0
Count of reserved physical eraseblocks:  11
Current maximum erase counter value:     0
Minimum input/output unit size:          2048 bytes
Character device major/minor:            253:0

seems ubifs cannot find any space available
I tried old openwrt , mounted /dev/mtdblock5 and got about 70% free
space but only afer nand format from routerboot. Rest is maked bad and
could be bad indeed..
but problem remains.. altho I have enough to flash kernel, ubi does
not see that free space.

Any help from anyone is much appritiated.

On Wed, Jan 31, 2018 at 8:41 PM, Denis Periša <> wrote:
> Hi, Thanx for input ;)
> it's routerboard 433AH and 435G (rb433AH/435G)
> I've found out like `nand scrub` .. haven't tried it yet as I don't
> have nand tools compiled but will. But also I'm afraid it's not it.
> It is bug.. I had few new RB435G ordered for citiy wireless and they
> went from 0 to 100% bad during flash.. now shows 100% usage on kernel
> partition..
> however rootfs partition is intact by it. hm.
> no u-boot however , RooterBoot or something like it driving it.. would
> be nice to change it but I lack that kind of time to investigate it.
> On Wed, Jan 31, 2018 at 5:03 PM, Alberto Bursi
> <> wrote:
>> On 01/31/2018 01:56 PM, Denis Periša wrote:
>>> Hi all,
>>> I got this once before but sent it on RMA.
>>> anyhow, I did some flashing from jffs2 to ubifs and initramfs kernel
>>> image loaded up fine, but on sysupgrade it marked all my kernel
>>> filesystem as bad nand.. 0 space left. I know for sure this is just
>>> fake mark as I copied kernel just before in it and It happended before
>>> to me.
>>> ANY , ANY chance there is some nand tool that can re-check those
>>> blocks and recover it to zero state?
>>> thank you!
>> I've seen commands in uboot (popular bootloader) that can reset nand bad
>> blocks, you would need to connect to serial console by soldering pins to the
>> device's board and then using a TTL-USB dongle to connect your PC to it.
>> But if it keeps doing that it might be a bug in the OpenWrt firmware (that
>> can't use the NAND properly and then marks it as bad).
>> Would be useful to state what is your device.
>> -Alberto
>> _______________________________________________
>> Lede-dev mailing list

Lede-dev mailing list

Reply via email to