On Sat, Oct 16, 2010 at 02:59:48AM +0100, Ken Moffat wrote:
> On Fri, Oct 15, 2010 at 06:00:19PM -0700, Chris R. Jones wrote:
> > On Fri, Oct 15, 2010 at 10:37:13PM +0100, Ken Moffat wrote:
> > > On Fri, Oct 15, 2010 at 02:26:29PM -0700, Chris R. Jones wrote:
> > > > 
> > > > Any other ideas why could have gone wrong with my dynamic loader?
> > > > 
> > >  Just a wild guess: missing /usr/lib64 symlink ?
> > > 
> > 
> > Thanks for the reply, but no - /usr/lib64 and /lib64 symlinks are both 
> > there.
> > Any other ideas?
> > 
>  Only the usual "ubuntu prefers wrong packages" response (sh -> dash,
> awk -> mawk), but I don't think you would have got this far if you
> hadn't fixed those.

As best I can tell it's not related to these.  Actually my awk does -> mawk.
What's a better choice for LFS, gawk?  I tried running with awk->gawk and
didn't see much different.

But as you say, I think I'm past the point where that would matter.

Instead, what seems to be going on is that my ld.so.cache is old.  The 
last time ld.so.cache is generated for me is in step 6.9.  At that point,
zlib isn't yet installed, so, obviously ldconfig won't find any version
of the library.

When zlib is installed in step 6.11, it doesn't seem to be running ldconfig, 
like it should.  I tried grepping through the zlib sources, and my step 6.11 
make output, and it doesn't seem to be running ldconfig.

So, if I dump the cache right at the beginning of step 6.12:

  root:/# ls -l /lib/libz*
  lrwxrwxrwx 1 root root     13 Oct 22 04:10 /lib/libz.so.1 -> libz.so.1.2.5
  -rwxr-xr-x 1 root root 107087 Oct 22 04:10 /lib/libz.so.1.2.5
  root:/# /sbin/ldconfig -p | grep libz

I get nothing - even though libz is in fact installed in the right places, the 
loader won't find it.  And so, in step 6.12, things fail.

If, right before step 6.12, I manually run ldconfig, the cache is all better,
and step 6.12 runs flawlessly.

So, since best I can tell, the libz sources never run ldconfig, I'm sort
of stumped on how this could be working for anyone.  What did I miss?  

What does you ldconfig -p show before and after step 6.11 where zlib is

FAQ: http://www.linuxfromscratch.org/lfs/faq.html
Unsubscribe: See the above information page

Reply via email to