On Wed, Feb 14, 2018 at 02:28:06PM +0100, René Nyffenegger wrote:
>    I also paid too little attention: my gcc version is 7.3.0 and the book
>    explicitely states that versions +4.4.1 are not recommended.
>    Similar thing with glibc which is version 2.26 (versions +2.10.1 not being
>    recommended).
Hi René,

you seem to be misreading what the book says.  The current stable
book is 8.1, and the following specific minimum versions are

gcc-4.7 (you imply versions > 4.4.1 are not tested)

As Pierre said, gcc-7.3.0 did not exist when 8.1 was released.  In
practice it should be fine for building 8.1

And glibc-2.26 is the highest version which had been tested, so it
is explicitly OK.

In other words, the versions you have mentioned are fine.  We also
say "Earlier versions of the listed software packages may work, but
have not been tested."

The things which commonly break a build are:

 /bin/sh not pointing to bash.

 host systems without bison (i.e. with a different yacc).

 mawk instead of gawk.

 missing packages from the list of requirements.

>    I probably have to somehow first bild an old version of gcc and glibc
>    before I can even think about
>    trying to create my own LFS.

No, building an older version of gcc is a recipe for pain - you can
probably go back one or two versions, but sooner or later the
current version will not understand the older source, particularly
in g++).

Truth, in front of her huge walk-in wardrobe, selected black leather
boots with stiletto heels for such a barefaced truth.
                                     - Unseen Academicals
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Do not top post on this list.

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing in e-mail?


Reply via email to