On Mon, Dec 17, 2001 at 01:21:00PM -0500, Glenn Maynard wrote:
> Should mkdirJob::Reuse() call super::Reuse()?

No, it should not. It is not virtual. Maybe it should be renamed to avoid
name collision.

> I'm still bashing on OutputJob.  It's working well now.  It should be
> possible, eventually, to support things like redirection to remote files
> and redirection to URLs, which would be extremely useful.  Even now,
> the statusbar gets reenabled if the output goes idle (ie. cls dir/
> dir2/) and having buffered output is very simple.

Be careful with redirection to remote files. Output position can jump back,
and the task calling session->Write should account for it.

> module.cc: change XXX to TODO.
> 
> buffer.cc buffer.h: add GetPos() and vFormat.
> 
> FileCopy.cc: FileCopyPeer can_seek and can_seek0 default to off; enable it in the
> derived classes.  (FileCopyPeer can't seek, since it's a buffer.  I
> guess FileCopyPeerString can, in a sense--since it's a one-shot buffer.)
> GetPos() and can_seek make FileCopyPeer usable standalone, as a source
> peer with external data.  (Basically, pretending it's
> "FileCopyPeerBuffer".)
> 
> FileCopy.h: Allow re-disabling AllowWrite and finding out if a FileCopy
> is line-buffered.  (Both are used to allow reenabling the status and
> again.)
> 
> "colored ls" -> "cls" in lftp.conf (they're both colored).  Add
> "reconnect" alias that I've used for a while.

Patch applied.

> Problem with FileCopy.  It seems to depend on the date setting to wait for
> completion.  (To see this, add c->DontCopyDate(); to CopyJob::CopyJob and do
> an upload; it was dependent on that to wait for completion correctly.)

I'll check that.

> Similar things happne with LocalAccess.  I've made an attempt at fixing
> this:
>  make Ftp::StoreStatus work like Done (not change anything), make SendEOT
>  virtual, call SendEOT explicitely from FileCopy; and move date stuff from
>  StoreStatus to SendEOT in FileAccess derivatives

I don't like that. Quite some time ago it worked that way, and I simplified it
by removing SendEOT from public methods. StoreStatus should be enough. It
could even be merged with Done.

-- 
   Alexander.                      | http://www.yars.free.net/~lav/  

Reply via email to