On Fri, Sep 28, 2012 at 11:26:12AM +0200, Diego Biurrun wrote:
> --- /dev/null
> +++ b/libavcodec/libopus.h
> @@ -0,0 +1,43 @@
> +
> +static int ff_opus_error_to_averror(int err)
> +{
> + switch (err) {
> + case OPUS_BAD_ARG:
> + return AVERROR(EINVAL);
> + case OPUS_BUFFER_TOO_SMALL:
> + return AVERROR_UNKNOWN;
> + case OPUS_INTERNAL_ERROR:
> + return AVERROR(EFAULT);
> + case OPUS_INVALID_PACKET:
> + return AVERROR_INVALIDDATA;
> + case OPUS_UNIMPLEMENTED:
> + return AVERROR(ENOSYS);
> + case OPUS_INVALID_STATE:
> + return AVERROR_UNKNOWN;
> + case OPUS_ALLOC_FAIL:
> + return AVERROR(ENOMEM);
> + default:
> + return AVERROR(EINVAL);
> + }
> +}
> --- a/libavcodec/libopusdec.c
> +++ b/libavcodec/libopusdec.c
> @@ -28,34 +28,13 @@
>
> -static int opus_error_to_averror(int err)
> -{
> - switch (err) {
> - case OPUS_BAD_ARG:
> - return AVERROR(EINVAL);
> - case OPUS_BUFFER_TOO_SMALL:
> - return AVERROR_UNKNOWN;
> - case OPUS_INTERNAL_ERROR:
> - return AVERROR(EFAULT);
> - case OPUS_INVALID_PACKET:
> - return AVERROR_INVALIDDATA;
> - case OPUS_UNIMPLEMENTED:
> - return AVERROR(ENOSYS);
> - case OPUS_INVALID_STATE:
> - return AVERROR_UNKNOWN;
> - case OPUS_ALLOC_FAIL:
> - return AVERROR(ENOMEM);
> - default:
> - return AVERROR(EINVAL);
> - }
> -}
This could or should possibly be moved to a .c file instead to avoid
code duplication in the binary. Is there a threshold for when to go
for a .c file instead of a header?
Diego
_______________________________________________
libav-devel mailing list
[email protected]
https://lists.libav.org/mailman/listinfo/libav-devel