On Tue, 26 Feb 2013, Diego Biurrun wrote:

This is more correct, as these two functions are meant to be internal and
it will allow reusing them from other libraries, e.g. libswresample.
---
libavcodec/avcodec.h |    2 ++
libavcodec/utils.c   |   20 +++-----------------
libavcodec/version.h |    3 +++
libavutil/internal.h |   25 +++++++++++++++++++++++++
libavutil/log.c      |   34 ++++++++++++++++++++++++++++++++++
5 files changed, 67 insertions(+), 17 deletions(-)

diff --git a/libavcodec/avcodec.h b/libavcodec/avcodec.h
index 7a24775..ad8744e 100644
--- a/libavcodec/avcodec.h
+++ b/libavcodec/avcodec.h
@@ -4559,6 +4559,7 @@ void av_fast_padded_malloc(void *ptr, unsigned int *size, 
size_t min_size);
 */
unsigned int av_xiphlacing(unsigned char *s, unsigned int v);

+#if FF_API_AV_LOG

Please use a less overly broad and generic name for this - based on this naming, one could think that the normal av_log api would be going away.

// Martin
_______________________________________________
libav-devel mailing list
[email protected]
https://lists.libav.org/mailman/listinfo/libav-devel

Reply via email to