On 31/07/13 15:50, Ben Avison wrote:
>> Probably would be better making it a mathop so it is more self
>> describing. Given the impact sounds a good idea.
>
> Something like this, you mean? I'm open to suggestions of a snappier
> name...
MOD_UNLIKELY probably is a better name.
> #ifndef MODULUS_WHERE_DIVIDEND_IS_LIKELY_INCREMENTED_BY_DIVISOR
> # define
> MODULUS_WHERE_DIVIDEND_IS_LIKELY_INCREMENTED_BY_DIVISOR(dividend,
> divisor, prev_dividend, modulus) \
> do { \
> if ((prev_dividend) == 0 || (dividend) - (prev_dividend) !=
> (divisor)) \
> (modulus) = (dividend) % (divisor); \
> (prev_dividend) = (dividend); \
> } while (0)
> #endif
Pretty much.
lu
_______________________________________________
libav-devel mailing list
[email protected]
https://lists.libav.org/mailman/listinfo/libav-devel