Bug ID: 119192
           Summary: Expanded Font Name on Text Formatting toolbar
                    incorrect: Linux Libertine Display G
           Product: LibreOffice
           Version: release
          Hardware: x86-64 (AMD64)
                OS: Linux (All)
            Status: UNCONFIRMED
          Severity: normal
          Priority: medium
         Component: LibreOffice

1. Font Name drop-down on the Text Formatting toolbar does not show correct
when expanded.

2. Copy/Paste font only copies formatting for 2 characters.

Steps to Reproduce:
After reading a reddit entry on multiple ways to add equations, I started
researching advanced font features. It was an entry in the LO 6.1 release
announcement thread.


In the link above, a site was mentioned, and I used a document from that site
for experimenting:

All examples use: Lively_Alphabet.odp


When I clicked in the slide's text box for the word "FireFly", the Font Name
drop-down showed "Linux Libertine Display G".  I hovered over the Font Name
drop-down to see the popup text. It simply said, "Font Name". This worked as

However, when I clicked inside the Font Name drop-down, the "Linux Libertine
Display G" was not in the display. The first font in the list was a font I used
in a previous LibreOffice session. I expected to see "Linux Libertine Display


Still in Impress, I positioned the cursor at the beginning of the word
"Firefly". Using the right arrow key, I moved one character at a time. I
watched the Font Name drop-down box.  The value did not change. Worked as
expected. But what was not expected, it changes in Writer. See next step.


I highlighted the text and clicked ctrl-c to copy the word "Firefly", and then
selected File > New > Text Document.  In the new Writer document, I typed
ctrl-v to paste the word "Firefly".

I repeated the step where I positioned the cursor at the beginning of the word
"Firefly". The Font Name was initially correct (same as in the Impress
document). As I moved the cursor to the right, the Font Name in the drop-down
changed and became italic. I only moved two characters right, "F" & "i", before
this occurred. I hovered over the Font Name drop-down and the popup said, 
"Current font is not available". I continued right and the font remained

I expected the entire word, "Firefly" to be "Linux Libertine Display G", like
it was in Impress.

I did create a new slide in Impress and copy/pasted the word, and did the same
test, and the entire word was "Linux Libertine Display G". It was only when I
copied it to Writer that only 2 letters had that format.

I opened the same Impress document in and immediately I could see the
font name in the Font Name drop-down box was Italic.  When I did the
copy/paste, the two character issue was the same, plus something really weird
happened to F11 Styles and Formatting. By weird, I mean garbage styles.
Unrecognizable text. This did not happen in

This might be related:

Environment: LM 17.3, LibreOffice

Actual Results:
1. "Linux Libertine Display G" did not appear in the Font Name drop-down.

2. Only the first two characters of a word, that was copied from Impress to
Writer, had the correct formatting. 

3. Only in, when word was copied from Impress to Writer, unrecognizable
Style Formats were created (F11).

Expected Results:
1. When the Font Name drop-down arrow was clicked, expected to see  "Linux
Libertine Display G".

2. When the word was copied from the Impress text box and pasted in a newly
created Writer document, that the entire word's formatting would be copied too.

3. to work like, which did not create unrecognizable style

Reproducible: Always

User Profile Reset: No

OpenGL enabled: Yes

Additional Info:

You are receiving this mail because:
You are the assignee for the bug.
Libreoffice-bugs mailing list

Reply via email to