On Fri, 26 Jan 2007, Simon Josefsson wrote: > You could write a non-blocking version of those functions and calling > them: > > int libssh2_async_sftp_init(..., LIBSSH2_SFTP **sftp) > int libssh2_async_sftp_open(..., LIBSSH2_SFTP_HANDLE *sftph)
[...] > Of course, change the names to something more appropriate if you want. > Perhaps 'libssh2_sftp_init_nb' and 'libssh2_sftp_open_nb' etc? Hm, right. That would of course be possible, although it would almost double the number of public functions in the library. Perhaps the benefit of not breaking the existing API outweights the drawbacks. Having this concept it would also possibly be easier to mix what kind of behaviour you want in your application, like you can do the init and open in a blocking manner but do the transfer phase non-blocking etc. I think I like this idea. It would also make it clearly which functions that would work non-blocking since we'd only implement those that truly are... ------------------------------------------------------------------------- Take Surveys. Earn Cash. Influence the Future of IT Join SourceForge.net's Techsay panel and you'll get the chance to share your opinions on IT & business topics through brief surveys - and earn cash http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV _______________________________________________ libssh2-devel mailing list libssh2-devel@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/libssh2-devel