Lukas-Fabian Moser <[email protected]> writes: > David Kastrup <[email protected]> schrieb am Do., 27. Aug. 2026, 11:11: > > I am leaning towards >> >> \book Book ly:book? "book" >> \bookpart Bookpart ly:bookpart? "bookpart" >> * Book_item ly:book-or-bookpart? "book or bookpart" >> > > The whole discussion is 1-2 storeys above my pay grade, so sorry for piping > up. I just want to second the doubts whether it's really a good idea to use > the term "item" here, which has a very specific and well-defined meaning in > LilyPond lore.
It would be invisible to anybody but C++ programmers. I think I'd get crucified for a class Book_or_bookpart . I thought of Book_pages, but pages actually are what ends up in a Paperbook, not a Book. Bookish is really too sloppy. One could do Book_content, but frankly in C++ it seems more important to keep to C++ "lore" than to LilyPond lore. You can see that I did not feel like letting the class hierarchy actually bleed over into Scheme/LilyPond: "book or bookpart" is glossing over the base class as a named entity. -- David Kastrup
