I've got an annoying problem that I hope someone can provide some insight
to.  Dir8/8.5 Mac (not tested on Win).

The project is a software app which allows access to to different functions
via both a dropdown contextual menu (just using a field member) and also via
a menu system using installMenu.  Most of these functions call custom
dialogs using MUI. Both the menu and the dropdown trigger the same code.

There are also some sprites on stage with regular behaviors on them with the
usual mouse events.

When I call up a MUI from the dropdown it all works fine, but if I call it
from the menu, then it seems that clicking on specific items in the MUI box
is sending mouseUp events to the stage, so some behaviors are receiving
clicks.  It also screws up some other things in the code because I get
errors when closing the boxes.

I suspect that the offending items are offset from the topleft of the MUI by
the same amount as the offending sprites are offset from the topleft of the
stage.

The only workaround I have found is to have a global variable (I guess it
doesn't need to be global, but it must be accessible by everything) that
stores a reference to any open MUI (each MUI box has it's own parent script
so I store a reference to the object as I draw the box & set it to 0 when it
closes).  Then in each behavior with mouse events, it checks to see if there
is an open MUI & if so, it ignores the events.

This is annoying because it is a band-aid approach that is not well
encapsulated.  I need to add the code to every MUI parent script and every
behavior.  I know the fault is not in any other code because the MUIs do not
act this way if triggered from the dropdown field.

I have played with the 'Pause while Not Active' setting to no avail.

Any ideas?

thanks in advance


johnAq


[To remove yourself from this list, or to change to digest mode, go to 
http://www.penworks.com/lingo-l.cgi  To post messages to the list, email 
[EMAIL PROTECTED]  (Problems, email [EMAIL PROTECTED]). Lingo-L is for 
learning and helping with programming Lingo.  Thanks!]

Reply via email to