Hi Guys!

I'd like to ask you for advices and descriptions of your experience with 
booting ELKS from IDE devices. Looking at ELKS bug reports on GitHub I've 
noticed that some of ELKS users tried to make it work with such devices.

I've bought one of such 8-bit IDE controllers for my ancient 1984's XT 
Turbo: https://www.lo-tech.co.uk/product/lo-tech-isa-compactflash-pcb - 
this is different one than people mentioned in their bug reports. I've 
connected CF-IDE adapter to it and I've bought low capacity CF cards 
(16MB, 32MB, 64MB it's amazing how much more expensive these things are 
nowadays comparing to over 1GB's). I'm able to boot FreeDOS and run things 
like GEM or 80's arcades on my XT. Initially, this FreeDOS was booted from 
floppy just in order to install it on the CF card, after that it boots 
directly from CF card with no floppy disk required.

Unfortunately, I'm not able to boot any 'Unix' system. I've tried to 
install Minix on 16MB card, I can boot Minix from floppy. I've tried to 
boot ELKS from 16MB card, it's always the same - nothing appears, no error 
message, no stack trace, just usual information that system will be booted 
from drive C.

I'd love to hear any hints on possible reasons for it, e.g. mabye I'm 
using wrong image or doing something wrong trying to use dd to transfer 
image to the card?

Best regards,
Paul

--
To unsubscribe from this list: send the line "unsubscribe linux-8086" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to