On 2.01.19 г. 19:05 ч., David Sterba wrote: > This is repeating code and could be simplified ... to the original code. It does and this is intentional. What I've strived to do is make the idea of the code obvious and not try to reduce the total line of code. It is a massive improvement given the code which modifies extent_end triggers only in case ret is > 0. I discussed this with Johannes and he agreed with my assessment. > I'm not sure this patch is an improvement.
- [PATCH 0/4] Misc cleanups of btrfs_get_extent Nikolay Borisov
- [PATCH 3/4] btrfs: Refactor retval handling of btr... Nikolay Borisov
- Re: [PATCH 3/4] btrfs: Refactor retval handlin... Johannes Thumshirn
- Re: [PATCH 3/4] btrfs: Refactor retval handlin... David Sterba
- Re: [PATCH 3/4] btrfs: Refactor retval han... Nikolay Borisov
- Re: [PATCH 3/4] btrfs: Refactor retval... Johannes Thumshirn
- Re: [PATCH 3/4] btrfs: Refactor r... David Sterba
- Re: [PATCH 3/4] btrfs: Refact... Nikolay Borisov
- [PATCH 1/4] btrfs: Rename found_type to extent_typ... Nikolay Borisov
- Re: [PATCH 1/4] btrfs: Rename found_type to ex... Johannes Thumshirn
- Re: [PATCH 1/4] btrfs: Rename found_type to ex... Qu Wenruo
- [PATCH 2/4] btrfs: Consolidate retval checking of ... Nikolay Borisov
- Re: [PATCH 2/4] btrfs: Consolidate retval chec... Johannes Thumshirn
- Re: [PATCH 2/4] btrfs: Consolidate retval ... Nikolay Borisov
- Re: [PATCH 2/4] btrfs: Consolidate retval chec... Qu Wenruo
