Linux-Hardware Digest #846, Volume #14           Wed, 30 May 01 15:13:06 EDT

  Framegrabber PMC with driver ("Michael B. Matthews")
  Strange problem, related to sound and pcmcia (Edward Ned Harvey)
  RedHat 7.1 sur Compaq Deskpro ("jormungandr")
  X problems with Dell Latitude Xpi 133st (Steven Shapiro)
  Re: Shutting down Beep (The Doctor)
  Re: Can't get disk DMA with PIIX (reader of news)
  FA: Hayes ESP High Speed Serial Port - 16-bit ("1mikef")
  Re: RH 7.1 on laptop? HELP! (Ricardo da Silva)
  Re: Debian Potato webcam (Ricardo da Silva)
  Re: ide-tape.o errors (Leonard Evens)
  Re: SCSI problems (Leonard Evens)
  Re: how to set console colors (The Doctor)
  Re: Via VT82C686 Sound Card (Markku Kolkka)
  Genius HR6 usb scanner works with linux? (Mario Giammarco)
  Re: linux and the Mac (The Doctor)
  installing NIC ("Andrey Shcherbina")


From: "Michael B. Matthews" <[EMAIL PROTECTED]>
Subject: Framegrabber PMC with driver
Date: Wed, 30 May 2001 07:20:51 -0700

I'm looking for a video framegrabber PMC module with RS-170 input,
RS-170/RGB output, and Linux driver. I'm considering boards from both
Visicom (VigraVision) and Radstone (GA-2), but they have no Linux
drivers. Any ideas?
Thank you,


From: Edward Ned Harvey <[EMAIL PROTECTED]>
Subject: Strange problem, related to sound and pcmcia
Date: Wed, 30 May 2001 15:15:50 GMT

I've got a Dell Inspiron 8000 running Mandrake 8.0.
You can get details of my procedure and problem at but here's 
what it's about:

By default, the pcmcia doesn't work on this laptop.  If you insert a pcmcia 
card, the whole system instantly crashes.

So I download the newest package and install it.
Now, when I reboot, insert the pcmcia card, the system doesn't crash, but 
the card doesn't work properly.

Then, I install the package for a second time, and reboot, and the card 
works perfectly.  ...  BUT, the sound gets a little messed up.  (Details 

Ordinarily, with a problem like this, you'd think that there's a problem 
with irq's or something.  So to test this theory, I disabled the pcmcia 
package entirely.  (remove /etc/rc.d/rc5.d/S09pcmcia)
Of course, pcmcia doesn't start, but the sound is unaffected.  still messed 

This suggests that the problem is not with the pcmcia itself, but with the 
installer -- that during the part when it calls depmod or the like, it 
changes something for the sound modules.  Unfortunately, that's a subject 
that I don't fully understand.

Now, the details of what's wrong with the sound:
It can only play one sound at a time.  So on startup, the startup sound 
plays, and tricks me into thinking that sound works.  But then I do 
something else, like play a video game, and suddenly it's obvious that it's 
messed up.

I do keep regular backups of my system, so if anybody has a suggestion for 
some files to compare, I have both the before-version and the after-version.


From: "jormungandr" <[EMAIL PROTECTED]>
Subject: RedHat 7.1 sur Compaq Deskpro
Date: Wed, 30 May 2001 17:19:07 +0200

Je désire installer le RedHat 7.1fr sur mon (vieux) Compaq Deskpro XL 133.
J'ai donc downloadé sur un ftp assez rapide les iso, puis les ai gravés.Tout
Mais impossible de trouver, lors de la premiere phase d'installation, le
pour le lecteur CD, qui est cablé en SCSI (a la vente par Compaq). Le disque
dur SCSI ayant rendu l'ame il y a qlqs mois, j'ai du le remplacer par un IDE

Donc, il m'est impossible de trouver le bon drivers pour le CD ... meme sur
la D7 sup. (drivers.img). Qlq'un connait-il un moyen de contourner ce pb?
Dois-je upgrader le firmware (sur, uniquement des drivers
pour les proliants :0) ...

Merci par avance,



Crossposted-To: comp.os.linux.setup,alt.os.linux.redhat
From: [EMAIL PROTECTED] (Steven Shapiro)
Subject: X problems with Dell Latitude Xpi 133st
Date: 30 May 2001 16:03:36 GMT

I've installed Red Hat 7.1 (with XFree86 4.0.3) on an Dell Latitude XPi P133ST
(NeoMagic 2070 video controller) but I'm having some problems with the display
under X.  When I move a window it does not refresh properly (although anything
below the window does refresh properly).  Also, when I move the mouse to about
an inch from the right edge of the screen a small white square appears under
the mouse cursor and a vertical line of moving white dots also appears.  I've
played with the XF86Config-4 file, but I have not been able to remedy the
problem.  Although, I have not been able to find the horizontal or
vertical sync rates for the laptop screen, so I've been shooting in the
dark.  Any ideas how to fix this problem?




From: [EMAIL PROTECTED] (The Doctor)
Subject: Re: Shutting down Beep
Date: 30 May 2001 16:27:15 GMT

On Thu, 24 May 2001 00:11:35 +0200, Peter T. Breuer <[EMAIL PROTECTED]> wrote:
>Vladimir Laserman <[EMAIL PROTECTED]> wrote:
>> I'm already getting nervous because of the beep signal. I hate this
>> sound.
>> Any suggestions how to shut it down? (and don't tell me do disconnect
>> the beeper from the board).

Why would you WANT to get rid of the beep?
That's like not hearing a key-click when you type.

>Why not? You don't like it, so get rid of it.

Either he's too lazy to open up the box or else he wants it for programmes 
(like Ultima) that only support the console speaker.

>What beep precisely are you complaining about? If it's from an editor,
>you can tell the editor not to beep (for example, it's "nobeep" or
>"visualbell"  in vi). If it's your shell, look at its manual.

Setting the "visiblebell" shell variable in tcsh works if you have a visual
bell set up in your terminfo database.
But the visual bell isn't vissible from other VTs.I only used it because the
internal speaker on my old case didn't work.Now that I have a working
PIT-driven speaker I'll never go back to that non-vsynced nonsense.
(now if Linux had actual functionality for visual bells that worked even in
Shared VGA and XFree86...)

>But you should always be able to beep by echoing ctrl-G to an ansi
>terminal. That's what's meant to happen. I think you'd have to attack
>the ansi console driver in the kernel to get rid of it ... or find
>some Xdefaults option for xterm that turns it off ..

The xterm visual bell kind of sucks.It's basicly just a slight flicker.
(as X11 lacks even the rudimentary ability of flashing the screen without

You can send OSC codes to adjust the terminal emulator driver.
echo "^[[10;1000]"
That sets the frequency to 1000cps.
echo "^[[11;1000]"
And that sets the duration to one thousand milli-seconds. (i.e. one second)
So you can just set the frequency to 0 to disable the ^G "BEL" beep.


From: [EMAIL PROTECTED] (reader of news)
Subject: Re: Can't get disk DMA with PIIX
Date: Wed, 30 May 2001 16:50:10 GMT

On 29 May 2001 10:36:29 -0700, mr_roget <[EMAIL PROTECTED]> wrote:
>I'd greatly appreciate any advice for getting DMA working on my ide
>disk. I've scoured the lists, google, and read as much as I can of the

Does your controller support dma?  Judging
from cpu 100MHz it's an old system and
I doubt that you can have dma on old systems.


Reply-To: "1mikef" <remove -spam->
From: "1mikef" <[EMAIL PROTECTED]>
Crossposted-To: alt.os.linux,
Subject: FA: Hayes ESP High Speed Serial Port - 16-bit
Date: Wed, 30 May 2001 16:45:40 GMT

On Ebay:


From: Ricardo da Silva <[EMAIL PROTECTED]>
Subject: Re: RH 7.1 on laptop? HELP!
Date: Wed, 30 May 2001 09:59:56 -0700

Michael Meissner wrote:

Thanks for reply Michael.
Trident CyberBlade i7 is supposed to work on XFree86 4.0.3
(as listed at XFree web page). By the way, it's working.
Some ramdon hangs..., but I need make sure if this is a 
video x XFree problem.
Thanks again,

> Ricardo da Silva <[EMAIL PROTECTED]> writes:
> > I'm using RH 7.1 on my laptop, the video card is a
> > Cyber Blade i7 (not the same!).
> > RH 7.1 use the XFree86 4.... but (i don't know why..)
> > the X is linked to XSVGA from XFree 3.3.6, and its works fine.
> > It was the default instalation using Xconfigurator.
> (note, I work on GCC not Linux, so this is personal opinion)
> There are some older video drivers that were supported in XFree86 that are not
> supported in XFree86 4.0.3.  You can run a 3.3.6 server with libraries and
> commands from 4.0.3.  This is in fact why Red Hat Linux ships the older servers
> with 7.1.  I don't know if the Cyber Blade is one such, but it sounds like
> Xconfigurator thought so.
> --
> Michael Meissner, Red Hat, Inc.  (GCC group)
> PMB 198, 174 Littleton Road #3, Westford, Massachusetts 01886, USA
> Work:     [EMAIL PROTECTED]           phone: +1 978-486-9304
> Non-work: [EMAIL PROTECTED]   fax:   +1 978-692-4482


From: Ricardo da Silva <[EMAIL PROTECTED]>
Subject: Re: Debian Potato webcam
Date: Wed, 30 May 2001 10:09:57 -0700

I've a WebCam QuickExpress from Logitech and it's work(ed)
on my kernel 2.2.19 (from
I just downloaded and compiled the driver mod_quickcam
and load usb modules.
It's works fine now with kernel 2.4.2-2 (RH 7.1) too.

[]'s Ricardo.

Shayne Hourigan wrote:
> Hi all,
> I rarely get time to check these lists and offer my meager experience so
> if someone has an answer for me an email would be appreciated!!!!
> Shayne Hourigan  [EMAIL PROTECTED]
> I'm trying to get my Logitech Quickcam express up and running. I get
> miscellaneous errors all over the place from all the drivers I've tried.
> I'll try em again in a minute and copy the actual error text in here...
> but in the meantime
> I have an AMD MS-6378 Micro ATX M/board with 2 USB ports. It runs of VIA
> technology and causes no end of compatablility problems in Linux. Most
> of wich I have sorted.... I only have the webcam to go in hardware, then
> onto my specialised software.
> I'm running the Potato dist. of Debian
> I have compiled my kernel (2.2.19pre17) with USB enabled... I haven't
> chosen specific modules in the section because I wasn't sure what
> modules would make the bloody thing work!
> Actually first I did try with the via module listed, on reboot I it
> picked up the usb-root hub and detected the camera as device 1, then
> continued on a bit further and assigned it to device 2 as well... then
> continued on again and reassigned it all over again... after that I gave
> up on that module and recompiled without the via option. It now compiles
> with usb support but doesn't auto-detect the device...... grrrrrrrrrrrrr
> This is my first attempt at getting a cam going on linux and after 3
> days of trying evry suggestion I could find on the web I'm ready to
> scrap the idea and just use the camera when I have to use Winblows (not
> my ideal situation as you folks would understand!)
> Any suggestions, hints, tips, or experience would be greatly
> appreciated.
> I have, however managed to get the vi686 sound chipset goingusing OSS if
> anyone needs that bit of info. It's not free software which sorta pisses
> me off, but it's the only one I found that actually will work properly.
> OK, well... thanks in advance for any help you folks may have.
> Shayne h.
> ***********************************
> There is no plot, this is reality, deal with it
> ***********************************


From: Leonard Evens <[EMAIL PROTECTED]>
Crossposted-To: comp.os.linux.setup,comp.os.linux.questions
Subject: Re: ide-tape.o errors
Date: Wed, 30 May 2001 12:06:25 -0500

Ga Mu wrote:
> I have an HP/Colorado 4/8 GB Travan-3 tape drive in a newly constructed
> RedHat Linux 7.1 system.  The tape drive is currently configured as
> /dev/hdd and I have /dev/tape linked to /dev/ht0.  (Or is that /dev/ht0
> linked to /dev/tape...)  I am trying to restore files from a backup made
> on another system. That system had no problem writing to the same drive
> (it was moved from the old system to the new).  mt commands appear to
> work fine.  E.g., I can retension the tape with 'mt retension'.
> However, tar can't read from the drive.  I get the following error
> messages when I try:
> -------------------------------------------
> [root@c1125351-a backup]# tar -xzf /dev/tape
> tar (child): /dev/tape: Cannot read: Input/output error
> <...snip...>
> [root@c1125351-a backup]#
> -------------------------------------------
> If I look in /var/log/messages, I see this:
> -------------------------------------------
> May 29 11:01:26 c1125351-a kernel: ide-tape: Reached idetape_chrdev_open
> May 29 11:01:26 c1125351-a kernel: ide-tape: ht0: I/O error, pc =  8,
> key =  5, asc = 2c, ascq =  0
> -------------------------------------------
> I remember having the same problem with the same error/log messages when
> I initially got the drive going in the original system.  Unfortunately,
> I can't for the life of me remember what I did to resolve the problem
> the first time.  Any help would be greatly appreciated!
> Greg

There have been several reports of HP ide tape drives not being
able to read with 2.4 kernels where they had had no trouble
with 2.2 kernels.  (Redhat 7.1 uses the 2.4.2 kernel.)  This is
really something that should be fixed, and I can't imagine it
will be terribly difficult since those drives have worked fine
since kernel 2.0.35.   But it is a matter of getting someone to
address it.   But for the moment, those of us with HP ide drives
are apparently out of luck.


Leonard Evens      [EMAIL PROTECTED]      847-491-5537
Dept. of Mathematics, Northwestern Univ., Evanston, IL 60208


From: Leonard Evens <[EMAIL PROTECTED]>
Crossposted-To: comp.os.linux.setup
Subject: Re: SCSI problems
Date: Wed, 30 May 2001 12:12:36 -0500

John English wrote:
> I've just installed Red Hat 7.1 on a machine at work which has an
> Adaptec 2940 SCSI controller, to which is attached a Fujitsu M2513A
> 640M magneto-optical drive. I've also got an HP 7100 IDE CD writer,
> which I've got set up for SCSI emulation as per the X-CD-Roast docs.
> I have problems with both devices...
> 1) I can mount a disk in the M-O drive, and I can list the contents
>    of the directory. As soon as I try to copy to or from the disk,
>    I either get a segmentation fault (following a null pointer) or
>    sometimes X freezes such that the mouse doesn't move and I can't
>    get out.
> 2) When I try to write a CD, it writes a few meg and then reports
>    a recoverable error. It then loops endlessly reading from the
>    drive (dunno why).
> Has anyone else got this hardware to work? Can anyone tell me what
> the problem is (or what other information I should post here about
> it)?
> TIA,

There have been other reports of problems with aic7xxx.  Browse
Bugzilla at the RedHat website.   I was concerned about this
because I have a machine with 2940 controller and a SCSI hard disk.
But I was able to install RedHat 7.1 without any problem.
Actually, originally the machine also had a SCSI CD drive, and
it was upgrading properly when the drive died.  I am pretty
sure this had nothing to do with the 2.4.2 kernel or the
RedHat installer.   The drive didn't respond properly even
just after the machine was turned on before Linux was loaded.
In any case, I put in a new IDE CD drive and installed RH7.1
without incident, and the disk seems to be functioning correctly.

> -----------------------------------------------------------------
>  John English              | mailto:[EMAIL PROTECTED]
>  Senior Lecturer           |
>  Dept. of Computing        | ** NON-PROFIT CD FOR CS STUDENTS **
>  University of Brighton    |    -- see
> -----------------------------------------------------------------


Leonard Evens      [EMAIL PROTECTED]      847-491-5537
Dept. of Mathematics, Northwestern Univ., Evanston, IL 60208


From: [EMAIL PROTECTED] (The Doctor)
Subject: Re: how to set console colors
Date: 30 May 2001 17:40:15 GMT

On 28 May 2001 00:10:35 GMT, Dances With Crows <[EMAIL PROTECTED]> wrote:
>On 26 May 2001 14:39:12 GMT, Johannes Zellner staggered into the Black
>Sun and said:
>>how can I set the palette for the console colors.
>>Either for the normal console or vesa (791 / 792 modes)

Look in console_codes(4) and search for "palette".
For instance...
echo "^[]P7123456"
Would set color #7 (the default colour) to have 0x12 of red,0x34 of green and
0x56 of blue.(hexadecimal digits)
And to reset the palette...
echo "^[]R"

>setterm -foreground $COLOR
>setterm -background $COLOR
>$COLOR can be black, red, green, yellow, blue, magenta, cyan, or white ,
>and you can add "bright" as a prefix to most of those.  Please note that
>any program that uses ncurses to manipulate the screen will overwrite
>your setterm settings upon program exit.  HTH,

That would not change the palette but merely which palette entries would be
specified in the attribute of new characters.
(unless they're written via one of the /dev/vcs or /dev/vcsa devices,in
 which case the colour of the old character is preserved)


From: Markku Kolkka <[EMAIL PROTECTED]>
Subject: Re: Via VT82C686 Sound Card
Date: 30 May 2001 20:53:12 +0300

"Pavan" <[EMAIL PROTECTED]> writes:
> > You need to enable "Sound Blaster" emulation in BIOS.
> Wrong, you should not enable that.

RH7 sndconfig installs the SB drivers for the VIA chip, if SB
emulation isn't enabled the system will get stuck at startup when the
sound drivers are loaded. The other alternative is to boot in rescue
mode with the install CD and fix the /etc/modules.conf file.

        Markku Kolkka


From: Mario Giammarco <[EMAIL PROTECTED]>
Subject: Genius HR6 usb scanner works with linux?
Date: Wed, 30 May 2001 19:01:34 +0200

I would like to know if a genius hr6 usb scanner works with linux.
Please do not tell me to look to the sane home page. 
I would like to know what chipset it has or to what scanner is similar.
Thanks in advance for any reply.
Mario Giammarco


From: [EMAIL PROTECTED] (The Doctor)
Subject: Re: linux and the Mac
Date: 30 May 2001 18:22:19 GMT

On Mon, 28 May 2001 03:30:20 GMT, Rinaldi J. Montessi
>Shore Linux Solutions wrote:
>> I am running rh linux 7.1 I have a zip disk that a friend of mine put
>> some
>> graphic files on for me.  However the zip disk was done on a zip disk
>> machine.  What I would like to do is mount the disc on the linux box and
>> transfer the files to the box.  However each time I attempt to mount
>> the file system it is telling me that it is an incorrect type.
>> The following command is the exact command I am entering (mount -t hfs
>> /dev/hdc /mnt/zip100.0)  I have no problems seeing windows formatted zip
>> disc but I cannot get this mac zip disc mounted at all.  I have even
>> looked in /proc/filesystems and I don't see hfs listed.  However when I
>> looked at the man page for mount and hfs is a valid type for the -t
>> argument.
>> Can you please direct me to anyway that I can properly view the contents
>> of a mac formatted disc?
>> Any help would be greatly appreciated.
>> AJ
>If you have your kernel source look in the /fs/hfs/FAQ.txt for more
>info.  There appears to be some further requirements for mounting other
>than the -t.

It won't do him any good until he compiles in support for HFS into Linux.


From: "Andrey Shcherbina" <[EMAIL PROTECTED]>
Subject: installing NIC
Date: Wed, 30 May 2001 14:40:40 -0400

Hi guyz,

I'm new to Linux. I've installed Debian distro with some NIC which drivers I
selected from the list. Now I need to replace that card with a newer one and
of course I need proper drivers. There's too many FAQs and HOWTOs so I'm
just lost. Could you please point me to the proper document on how to
install new hardware.

Thank you,



The service address, to which questions about the list itself and requests
to be added to or deleted from it should be directed, is:

    Internet: [EMAIL PROTECTED]

You can send mail to the entire list by posting to comp.os.linux.hardware.

Linux may be obtained via one of these FTP sites:                                pub/Linux                              pub/linux                             pub/Linux

End of Linux-Hardware Digest

Reply via email to