On Thu, 2016-09-08 at 12:48 +0200, Bartosz Golaszewski wrote:
> The register offset defines for the pca953x and pca957x expander
> families should have the same names to better reflect their similar
> purposes.



 
>       chip->regs = &pca957x_regs;
>  
> -     ret = pca953x_read_regs(chip, PCA957X_OUT, chip->reg_output);
> +     ret = pca953x_read_regs(chip, PCA957X_OUTPUT, chip-
> >reg_output);
>       if (ret)
>               goto out;
> -     ret = pca953x_read_regs(chip, PCA957X_CFG, chip-
> >reg_direction);
> +     ret = pca953x_read_regs(chip, PCA957X_DIRECTION, chip-
> >reg_direction);

Bu we may use chip->regs->direction here, right? And output before. 

>       if (ret)
>               goto out;
>  

-- 
Andy Shevchenko <[email protected]>
Intel Finland Oy

Reply via email to