On Tue, Oct 18, 2016 at 09:24:20AM -0600, Shuah Khan wrote:
> After upgrading to Ubuntu 16.10, I can't build kernels anymore unless
> the following patch is applied to the kernel Makefile. A word of
> caution for anybody that is planning to update their development
> systems.
> https://patchwork.ozlabs.org/patch/616621/
> Please refer to the Ubuntu 16.10 release notes for more details.
> https://wiki.ubuntu.com/YakketyYak/ReleaseNotes#GCC
> Ubuntu is recommended applying this patch for building Linux kernels.
> I am not sure this is the right way to go. I am hoping this is
> work-around and patching the kernel Makefile will not be the solution
> going forward.
> I haven't seen any patch sent upstream to make this change, so I still
> hope this is a temporary work-around. Maybe be there is patch that
> came through and you are aware of this problem?

Does commit 6d92bc9d483a solve this issue for you?  That should have
resolved a -pie issue, back in 4.6, or is this something else?


greg k-h

Reply via email to