On Wed, May 16, 2018 at 12:42:43AM +0000, Huang, Ying wrote:
> >> + unsigned long address = faddress & huge_page_mask(h);
> > faddress? I would rather keep it address and rename maked out variable to
> > 'haddr'. We use 'haddr' for the cause in other places.
> I found haddr is popular in huge_memory.c but not used in hugetlb.c at
> all. Is it desirable to start to use "haddr" in hugetlb.c?
Yes, I think so. There's no reason to limit haddr convention to THP.
Kirill A. Shutemov