On Tue, Jul 10, 2018 at 06:33:18PM +0100, Will Deacon wrote:
> On Tue, Jul 10, 2018 at 11:37:24AM +0100, Dave Martin wrote:
> > For the kernel, I suggest using a .L prefix so that the generated
> > symbols don't bloat the vmlinux symbol table (similar to numbered local
> > labels) -- unless you really want the symbols retained.
> > Having a common prefix for all "unique" assembler symbols may help us
> > to avoid namespace collisions, say
> > .L__asm__foo_\@
> > .L__asm__bar_\@
> Hmm, yes, and that would allow us to replace the open-coded labels in
> our assembler.h macros as well, wouldn't it?
For this patch, I'll rename skip_apply_ssbd\@ to .L__asm_ssbd_skip\@.
I'll send another patch (or series) converting our other macros to this
scheme. We can either take that with this series, or as subsequent