On Sat, Jan 26, 2019 at 05:32:19PM +0100, Jonas Bonn wrote:

> @@ -164,6 +166,7 @@ struct spi_device {
>       char                    modalias[SPI_NAME_SIZE];
>       const char              *driver_override;
>       int                     cs_gpio;        /* chip select gpio */
> +     uint16_t                word_delay;     /* inter-word delay (us) */

This needs some code in the core joining it up with the per-transfer
word delay similar to what we have for speed_hz and bits_per_word in
__spi_validate().  Then the controller drivers can just look at the
per-transfer value and support both without having to duplicate logic.

Attachment: signature.asc
Description: PGP signature

Reply via email to