> Add validation for num, bh and type on getting dir-entry.
> Renamed exfat_get_dentry_cached() to exfat_get_validated_dentry() due to a
> change in functionality.
> 
> Integrate type-validation with simplified.
> This will also recognize a dir-entry set that contains 'benign secondary'
> dir-entries.
> 
> Pre-Validated 'file' and 'stream-ext' dir-entries are provided as member
> variables of exfat_entry_set_cache.
> 
> And, rename TYPE_EXTEND to TYPE_NAME.
> 
> Suggested-by: Sungjong Seo <sj1557....@samsung.com>
> Suggested-by: Namjae Jeon <namjae.j...@samsung.com>
> Signed-off-by: Tetsuhiro Kohada <kohada...@gmail.com>

Reviewed-by: Sungjong Seo <sj1557....@samsung.com>

Looks good to me. Thanks.

> ---
> Changes in v2
>  - Change verification order
>  - Verification loop start with index 2
> Changes in v3
>  - Fix indent
>  - Fix comment of exfat_get_dentry_set()
>  - Add de_file/de_stream in exfat_entry_set_cache
>  - Add srtuct tag name for each dir-entry type in exfat_dentry
>  - Add description about de_file/de_stream to commit-log
> 
>  fs/exfat/dir.c       | 147 +++++++++++++++++--------------------------
>  fs/exfat/exfat_fs.h  |  17 +++--
>  fs/exfat/exfat_raw.h |  10 +--
>  fs/exfat/file.c      |  25 ++++----
>  fs/exfat/inode.c     |  49 ++++++---------
>  fs/exfat/namei.c     |  36 +++++------
>  6 files changed, 122 insertions(+), 162 deletions(-)

Reply via email to