On Thu, Jan 07, 2021 at 10:16:50PM +0300, Dmitry Osipenko wrote:
> 03.11.2020 06:57, Yejune Deng пишет:
> > devm_reset_control_array_get_optional_shared() looks more readable
> > 
> > Signed-off-by: Yejune Deng <yejune.d...@gmail.com>
> > ---
> >  drivers/usb/dwc3/core.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/drivers/usb/dwc3/core.c b/drivers/usb/dwc3/core.c
> > index 841daec..b87acf0 100644
> > --- a/drivers/usb/dwc3/core.c
> > +++ b/drivers/usb/dwc3/core.c
> > @@ -1490,7 +1490,7 @@ static int dwc3_probe(struct platform_device *pdev)
> >  
> >     dwc3_get_properties(dwc);
> >  
> > -   dwc->reset = devm_reset_control_array_get(dev, true, true);
> > +   dwc->reset = devm_reset_control_array_get_optional_shared(dev);
> >     if (IS_ERR(dwc->reset))
> >             return PTR_ERR(dwc->reset);
> >  
> > 
> 
> Greg / Felipe, could you please pick up this patch?
> 
> I want to add devm_reset_control_array_get_exclusive_released() for
> NVIDIA Tegra drivers and we need to get rid of all the open-coded
> devm_reset_control_array_get() users in order to extend the reset API
> sanely.

Care to ack it or send a reviewed-by for it?

thanks,

greg k-h

Reply via email to