On Wed, 2021-01-13 at 11:15 -0600, Alex Elder wrote:
> This series implements some updates for the GSI interrupt code,
> buliding on some bug fixes implemented last month.
> 
> The first two are simple changes made to improve readability and
> consistency.  The third replaces all msleep() calls with comparable
> usleep_range() calls.
> 
> The remainder make some more substantive changes to make the code
> align with recommendations from Qualcomm.  The fourth implements a
> much shorter timeout for completion GSI commands, and the fifth
> implements a longer delay between retries of the STOP channel
> command.  Finally, the last implements retries for stopping TX
> channels (in addition to RX channels).
> 
>                                       -Alex
> 

A minor thing that bothers me about this series is that it looks like
it is based on magic numbers and some redefined constant values
according to some mysterious sources ;-) .. It would be nice to have
some wording in the commit messages explaining reasoning and maybe
"semi-official" sources behind the changes.

LGMT code style wise :) 

Reviewed-by: Saeed Mahameed <sae...@nvidia.com>


> Alex Elder (6):
>   net: ipa: a few simple renames
>   net: ipa: introduce some interrupt helpers
>   net: ipa: use usleep_range()
>   net: ipa: change GSI command timeout
>   net: ipa: change stop channel retry delay
>   net: ipa: retry TX channel stop commands
> 
>  drivers/net/ipa/gsi.c          | 140 +++++++++++++++++++----------
> ----
>  drivers/net/ipa/ipa_endpoint.c |   4 +-
>  2 files changed, 83 insertions(+), 61 deletions(-)
> 

Reply via email to