On 7/13/26 16:16, Alice Ryhl wrote:
On Mon, Jul 13, 2026 at 02:45:31PM +0800, Alvin Sun wrote:
Module types now live in `rust/kernel/module.rs` alongside
`rust/kernel/module_param.rs`. Update the MODULE SUPPORT file pattern
from `rust/kernel/module_param.rs` to `rust/kernel/module*.rs` so both
files are covered.
Cc: Petr Pavlu <[email protected]>
Assisted-by: opencode:glm-5.2
Link:
https://lore.kernel.org/rust-for-linux/[email protected]
Signed-off-by: Alvin Sun <[email protected]>
---
MAINTAINERS | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/MAINTAINERS b/MAINTAINERS
index e035a3be797c4..74733de3e41ee 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -17984,7 +17984,7 @@ F: include/linux/module*.h
F: kernel/module/
F: lib/test_kmod.c
F: lib/tests/module/
-F: rust/kernel/module_param.rs
+F: rust/kernel/module*.rs
F: rust/macros/module.rs
F: scripts/module*
F: tools/testing/selftests/kmod/
Is there a reason why this is a separate commit from the commit that
introduces rust/kernel/module.rs file?
Gary asked the same on v6; `git log` shows MAINTAINERS changes are
conventionally
standalone commits with a `MAINTAINERS: ` prefix, so I kept it separate.
Gary agreed [1].
[1]:
https://lore.kernel.org/rust-for-linux/[email protected]/
Best regards,
Alvin
Alice