Use a named initializer for the acpi_device_id::id field for
readability and drop setting the list terminator fields
explicitly as well to be consistent with the rest of the kernel
code.

Signed-off-by: Pawel Zalewski (The Capable Hub) <[email protected]>
---
 include/linux/acpi.h | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/include/linux/acpi.h b/include/linux/acpi.h
index 60ab50cb8930..b34b483d99f5 100644
--- a/include/linux/acpi.h
+++ b/include/linux/acpi.h
@@ -805,10 +805,10 @@ int acpi_mrrm_max_mem_region(void);
 #endif
 
 #define ACPI_CMOS_RTC_IDS      \
-       { "PNP0B00", },         \
-       { "PNP0B01", },         \
-       { "PNP0B02", },         \
-       { "", }
+       { .id = "PNP0B00" },            \
+       { .id = "PNP0B01" },            \
+       { .id = "PNP0B02" },            \
+       { }
 
 extern bool cmos_rtc_platform_device_present;
 

-- 
2.43.0


Reply via email to