On Mon, Aug 03, 2026 at 11:58:02AM +0200, David Hildenbrand (Arm) wrote:
>
> >> The former would be better
> >>
> >>    __vma_set_start_anon_pgoff(dest, vma_start_anon_pgoff(src));
> >
> > Ack that's fair, will update it.
>
> But looking at the existing code
>
> vma_set_pgoff(vma, vma_start_pgoff(vma) - delta);
>
> etc, maybe we can keep it as is for symmetry.

Sure.

I mean putting start here is valid because you are setting the _start_ page
offset of the VMA, but then the field itself kinda has that implied.

Obviously could rename vma_set_pgoff() too but then it gets churny and adds
noise so makes sense leaving it as it is also... :)

>
> --
> Cheers,
>
> David

--
Cheers, Lorenzo

Reply via email to